Core options path being ignored [SOLVED]


I’m not sure when this bug began, but since some time ago, RetroArch seems to ignore any core_options file based on Content Directory. Instead of using the specified .opt file that I specify via Content directory override with: core_options_path = “:\config\FinalBurn Neo\SNK Neo Geo AES.opt”

It will just ignore the SNK Neo Geo AES.opt file and create a FinalBurn Neo.opt file instead.

This is common with different cores (fbneo and beetlepce), so I guess it’s something on RA itself.

I have some cores which I like to have separate core options file for different systems. For example, for NeoGeo AES and MVS I use different content overides, I have two config files “SNK Neo Geo AES.cfg” and “SNK Neo Geo MVS.cfg” for different options for my both SNK Neo Geo AES and SNK Neo Geo MVS rompaths. Inside SNK Neo Geo AES.cfg I specify: core_options_path = “:\config\FinalBurn Neo\SNK Neo Geo AES.opt” so it will use this specific core options file for my AES games. And the opposite for the MVS games.

This way I can launch NeoGeo games with FBNeo with separate instances for AES or MVS modes.

But now this does not work anymore. RA will always create the default FinalBurn Neo.opt file ignoring those files specified on the config files.

Strange thing, if I create a fatfury1.opt file fot specific options for fatfury1, it will work.

Can anybody confirm if this is a bug or something weird on my end?


Did you try turning “Use Global Core Options File” on in Configuration Settings? It was disabled by default awhile ago, and I’d imagine that would interfere with manually overriding core options files.

1 Like

My guess is that it has to do with global core options being disabled by default. That setting probably needs it enabled (if it still works).

Look for the option in Settings > Configuration.

1 Like

Oh man, that was it! Thank you so much, @Awakened and @metchebe. Indeed, the “global_core_options” was set to false on my main retroarch.cfg. I think now I understand what it does. To be able to use “core_options_path” you need to enable “global_core_options”, otherwise it will always use an options file located on the core config folder with core config name.

Got it, it’s not a bug.

Thanks so much guys!

1 Like