Crackling audio with Swan Station core when I turn on video sharders

Hey folks. Recently, I’ve been messing with CRT Shaders on Retroarch. They work perfectly fine on SNES games, but when I load them on SwanStation, the audio starts to crackle occasionally. I’ve tried the following things to solve the problem so far:

  • Turning VSync off: did solve the problem, but it also causes screen tearing.
  • Adjusting the Vertical Refresh Rate: apparently solves the problem. It seems it temporarily fixes it if I change it to the Estimated Screen Refresh Rate during game (when I open a game, it goes from 143,85Hz, the refresh rate that my monitor is set up to use, to ~60Hz), but when I close the game and open it again the audio crackles start again.
  • Changing Audio Latency or audio or video drivers: no differences.

I’m currently running Pop!_OS 22.04 on my computer (Ubuntu-based Linux distro). My CPU is a Core i3 12100F, my GPU is a GeForce GTX 1070, and I have 16GB of RAM. My monitor is an Asus TUF Gaming VG247Q1A, which supports FreeSync and can output up to 165Hz.

Shaders are programs that run once for each pixel, so if you increase the internal res, it also increases the performance impact of the shader. For example, a 2x scale in a core increases the number of pixels (and therefore the cost of the shader) by 4x, since it’s 2x on the horizontal axis and 2x on the vertical axis.

Forgot to say that I didn’t upscale the core resolution (unless changing the settings in Settings > Video > Scaling to use Integer scaling also makes the shader heavier).

Integer scaling won’t make it heavier, but PS1 games frequently use a higher resolution mode (especially in menus and in the BIOS animation) that can have the same effect.

The audio stutters in even outside menus or boot screen, so I doubt the higher resolutions are causing this. Changing the Vertical Refresh Rate helped me, thought the problem started again when I restarted the game. Maybe it has something to do with the Refresh Rate?

It shouldn’t act any differently than an SNES core when it comes to refresh rate.

If you hit spacebar, how much faster than 60 fps does it go? (note: you’ll need to go to settings > frame throttle and set ‘Fast-Forward Frameskip’ to OFF first or this won’t really tell us much/anything)

What shader are you using?

Try glcore drivers then:

Settings -> Video -> Syncrhonization

and use this settings

119 FPS with Fast-Forward.


I’ll try glcore again with this settings, thanks.

1 Like

Changing the driver + settings worked! TYSM!

1 Like

I’m glad it all worked out! :partying_face:

UPDATE: already solved the problem by doing the following steps:

1 Like