Crappy Laptop > Ubuntu MATE > Low framerate

Farting around on an old laptop. Decided to try RetroArch … I cant seem to get the refresh above 40ish. Well, i can in a window. A small window with go higher than a larger window. Really strange. Any ideas?

This is full screen with windowed off

if it loses frames as the window gets larger, that typically means you don’t have hardware acceleration. If I had to guess, I would say it’s using a soft-GPU.

Hmm. Any idea how to change that?

The system monitor says the GPU is Mesa DRI Mobile Intel GM45 Express Chipset (CTG)

what video driver are you using in RetroArch? Also, can you pastebin a verbose log?

GL. I tried all the GLs and Vulkan. RA doesn’t start with anything other than GL

When i figure out how to do it in Linux. I suck at Linux, heh.

easiest thing to do is launch from a command line like this:

retroarch --menu --verbose >> log.txt

I’ll try that next … i did

First We’ll need to activate the Advanced Settings:

  1. Go to settings
  2. Enter at “User Interface”
  3. Activate “Show Advanced Settings” Next We’ll activate the logging option:
  4. Go to settings if you weren’t there
  5. Enter at “Logging”
  6. Activate “Log to File” 4.(optional) Customize Core & Frontend Logging Level & if you want timestamps or performance counters on your log
  7. Activate “Logging Verbosity”

but where does the log get saved? lol

That works, too. it goes into your ‘log’ directory. If there’s a default setting on Linux, it’s probably ~/.config/retroarch/logs or something like that.

Pasted above :stuck_out_tongue:

Moar characters!

Try running from a command line and see if making the window bigger makes the FPS drop:

vblank_mode=0 glxgears

Same thing running retroarch from terminal. Running retroarch vblank_mode=0 glxgears doesn’t start anything.

just run the above command, not with ‘retroarch’ in front of it. GLXGears is its own thing.

Ahh, lol. The gears run at a much lower FPS with a bigger window. Also windows tear when moving around.

1 Like

Tried Mint Cinnamon. Same deal :’(


I’ve had the 40 fps issue on my Chromebook with Intel Graphics before and it was an issue with the kernel (4.16 if I recall correctly). I found bug reports on this online.

On Ubuntu 20.04 I also encountered issues with kernel 5.8, which I fixed by installing and using kernel 5.4.

So in my experience you most likely have to try a different kernel and see which works best.

1 Like

Probably because there is no driver for your graphics card in the kernel. First things first you should give full specs of the laptop.


Thanks metchebe, i’ll look into that. Though im not sure i could figure out how to change the Kernel, lol.

[INFO] CPU Model Name: Pentium® Dual-Core CPU T4200 @ 2.00GHz


Intel doesn’t say what the iGPU is when i look it up but linux says the GPU is “Mesa DRI Mobile Intel GM45 Express Chipset (CTG)”

Edit: GMA 4500MHD GPU?

Tried a distro that comes with 5.4 and got the same results. Updated it to a newer version of 5.4 and… same. I’m just going to give up now :slight_smile:

what is the model of the laptop, should be written in a sticker under. Then someone can find the full specs and check what is wrong.