CRT Royal shader on Nvidia Shield pro crashing

hmm, yeah, exact same result. I’ll see if I can reproduce on my end.

Yes, exact same result. I installed the following apps on my Nvidia, maybe one of them is conflicting.

  1. RetroArch - I clicked under Android on download, the link above download (64bit) https://buildbot.libretro.com/stable/1.10.3/android/RetroArch.apk
  2. Amazon Downloader
  3. File Manage (very basic)
  4. X-plore

Hi Hunterk,. One thing I forgot to include is that when scanning for the Mame2003 Roms, I also added the games list . If I am not wrong it’s an XML file, but this is not the reason for RetroArch to crash when enabiling CRT Royal shader correct?

Not sure, but it shouldn’t affect any other cores, certainly.

Did you manage to reproduce the same results as to my log file?

I haven’t gotten a chance to try it yet, sorry.

Yes, I understand you very well.

Based on this forum they managed to get CRT royale running on an Nvidia Shield:

On the link above they did not explain what they did to run CRT Royal

I finally got a chance to try it on my Shield, and it crashed the same way as for you. I haven’t used RetroArch on it in quite some time, so this was using an old version of RetroArch and shaders that definitely worked with royale the last time I tried it. The only change is that my Shield has been fully updated.

So, this leads me to believe that Nvidia broke something with one of their updates, which unfortunately isn’t really something we can fix.

Shield user here and just to chime in I can confirm Royale works on my Shield but I’m still on the last 8.2.3 update, never updated the Shield to the latest version and this gives me yet one more reason not to.

1 Like

Thank you Huntertek for your time. Thank you sonkun for your help as well. I’m currently on 9.0. Did someone try the latest 9.1 update? I read that they fixed many gaming issues and they also added a low lag feature for gamers. The new update is more focused on fixing problems instead of adding new features.