CRT Royal shader on Nvidia Shield pro crashing

Can someone guide me with the best settings to apply CRT royal shader on Nvidia Shield pro as I when I do, RA crashes. I would like to set CRT Royal because it’s the closest to a real CRT screen, I tried the following settings without success:

I set the video to Vulcan and connected my Nvidia Shield pro to a 4K TV and I updated the shaders.

Are you running your shield in 1080p or 4K? It should be able to run the shader fine at 1080p but 4K isn’t full speed (though it shouldn’t be crashing in any event). Which core(s) have you tried it with? if it’s anything that can increase internal res, you’ll need to run it at native/1x res to avoid crashing because res increases multiply the effective resolution that the shader applies to.

In the mame core, do you have the “alternate render” core option enabled? Can you try it with, say, snes9x as a sanity check? If that crashes, too, I’ll need to see a log. See here for instructions:

Thank you for your help hunterk. I need to find out how to alternate and enable the core option as I’ve no idea how to enable it.

I am trying on a 4k TV and an old LCD monitor, I think it’s a 1080p. After loading a game with the Mame core, I access the RA menu and I go to shader and I click on load the Royal shader, the RA freezes for a couple is seconds and after it crashes RA and I am bounced to the Android menu. Other shaders such as Geom load fine without issues, but I would like to be able to use the Royal shader as all the shaders use horizontal scanlines except to the CRT Royal shader.

enabling the alternate render core option will cause it to crash (probably) because it makes it increases the resolution. I was just asking in case you had turned it on.

I’ll need you to post a log and try with another core to learn anything more.

I searched on the RA settings and I can’t find where are the alternate render settings. Would you mind indicating me in which section I can find them?

It’s in quick menu > controls while the mame core is running a game. It’s not enabled by default, though, so if you didn’t set it, it shouldn’t be enabled.

I can’t find it, Is it called alternate render?

should be something like that, but it may not even be in the core anymore. You’re getting in the weeds here. Just post a log of it crashing.

Yes I will post the log. Although I’ve recently installed Retroarch.

Hi Hunterk, thank you again for your help. I factory reseted my Nvidia Shield pro, although CRT Royal shader is still crashing. The Log app download is not available on the link which you posted I tried searching for it on the same web page, but I had no luck. On playstore I found Logcat app. However I could not download it as on plaster they added that it’s not compatible with my Nvidia Shield pro. Would you mind suggesting another solution?

you don’t need any app. you can do it from the menus. Follow the “generating logs from the menu” instructions.

From the Retroarch menu?

yes, from the retroarch menu

Finally, I did it. Please find the log data hereunder. Basically what I did are the following things:

  1. I factory reset my Nvidia Shield pro
  2. Installed RetroArch
  3. Set Retroarch to Vulcan saved and closed
  4. Updated GLSL Shader
  5. Loaded a game and back to menu/shader and I clicked on load CRT Royal and RA frozen and after a few seconds, it bounced me back to the Nvidia Shield menu.
  6. I uploaded the link of the Log file on this website

If you could guide me on how to use CRT Royal shader I will greatly appreciate it.

I hope the above is correct. Thank you in advance :slight_smile:

Eyyy, this looks great, thanks!

Hmm, I don’t see any specific error, but I do see one very suspicious line:

[Vulkan filter chain]: Creating framebuffer 1440x1080 (max 1 level(s)).
[Vulkan filter chain]: Creating framebuffer 1440x1080 (max 1 level(s)).
[Vulkan filter chain]: Creating framebuffer 1440x1080 (max 1 level(s)).
[Vulkan filter chain]: Creating framebuffer 1440x1080 (max 4294967295 level(s)).
[Vulkan filter chain]: Creating framebuffer 1440x1080 (max 1 level(s)).

Can you guess which one looks abnormal? lol

I’m not sure what to do about this, though. I’ll have to fire my Shield up and see if I can reproduce it. Have you tried any other cores? like snes9x?

Thank you so much for your prompt reply. Yes, I tired now with SNES9x - Current core, and it crashed in the exact same way. I am trying on both Snes and Mame2003 cores to load crt-royal.slang. Shall I also upload the log file?

I think you’re referring to this line [Vulkan filter chain]: Creating framebuffer 1440x1080 (max 4294967295 level(s)).

1 Like

heh, yep, that’s the one. If you have the log from snes9x handy, sure, i’d love to see it.

Yes sure I will, but tomorrow because here it got late 22:59. I hope there is a chance that I will be able to use CRT Royal. Thank you again

1 Like

Hi hunterk, here is the SNES core log file. As per my previous message before that installed RA app I factory rested my Nvidia Shield Pro. I forgot to include that before I factory rested my Nvidia when loading only Mame2003 roms with Geom shader, RA was bouncing me back to the Nvida menu. This is no longer happening except to when I try CRT Royal shader. Thank you again :slight_smile: