CRT switchres crashes RA

Hi - Recently updated to the latest nightly and upon enabling CRT switchres in RGUI, RA simply exits to desktop literally as soon as you move it to anything but “off”.

Not sure what changed here. Worked fine in my older version. If this broken on RA now?

Maybe. If it is, we’ll need your help to figure out when it broke.

if you can try different nightly builds until you find the latest one that doesn’t crash, we should be able to narrow it down to the exact commit that broke it.

Before that, though, have you verified that it happens with a clean config (i.e., move your retroarch.cfg somewhere else and then let it create a new one with default values)?

Hi Hunter.

I can’t remember what version I upgraded from but google searches show Reddit posts stating last version it worked for others was 1.9.4.

Let me look tonight and for sure tell you what version I was using previously where it worked.

That was a very long time ago. It’s definitely worked since then. I suspect something else is going on.

Ok, let me see when I get home if I can see what I upgraded from. I save all my RA upgrade files I download from nighties so I will let you know.

EDIT: It seems I upgraded from 1.8.4. Yikes. That’s a hell of a jump. I’m going to start testing stables and report what I find.

So, bad news. Switchres works on 1.9.4.

1.9.5 and after once you enable switchres RA crashes.

So on the Reddit posts I read they said Alphanu supposedly made a bunch of changes to switchres starting with 1.9.5. They said because of that it broke.

I’m not even sure if Alphanu is still around anymore to look into this.

If that’s the case, it’s a shame because CRTSR is pretty much integrated now and a lot of people use it. I certainly do. I’m still on RA 1.9.0 actually, so I haven’t had this issue.

Actually, I’m looking through the change logs, and it looks like there was a fix for “Fixed monitor index corruption on Windows” which could explain things.

I’m assuming you have CRU on your system? If you don’t, you really, really need that for CRTSR. You have to go in and delete all the resolutions for the CRT that you don’t want and create detailed resolutions for the Native Res’s, and then Standard resolutions and extension blocks for everything else.

There’s also a utility that is on the CRU forum that lets you delete all the scaled resolutions that Nvidia/AMD keeps throwing out weirdly. It doesn’t work with Intel.

Assuming you already did all that, try going into CRU folder and resetting the monitor indexes with the included utility.

Ok. I just downloaded 1.12.0 and CRTSR seems totally fine for me. No issues here. Try CRU (custom resolution utility). I think you’ve got some issues with video control in windows; it can get really complicated between the Nvidia control and windows and RA.

1 Like

I run crt emudriver on Windows 10x64.

All the tools included take care of the resolutions. CRU is not needed.

I’m running Windows 10x64 and I have zero issues with CRTSR in retroarch 1.12.0. I downloaded it and tested it out last night just to help troubleshoot and I could find no problems.

There is mention in the changelogs of “windows monitor index corruption” for CRTSR, and that might be your issue.

I’ve got Custom Res Utl on my PC and I’m running up-to-date Nvidia drivers. Everything is spiffy no issues. Before I ran the Scaled Resolution Utility, I was having lots of problems with Nvidia randomly choosing it’s own resolutions and interfering with the windows monitor index.

If you don’t think you need it, ok, but I have no other suggestion.

1 Like

Appreciate the response, I really don’t know then if this is specific to a change with retroarch 1.9.5 that affects people running crtemudriver/ati cards only?

Nothing has changed on my end at all but upgrading RA.

There has to be other users here using crt emudriver. I’d like to know if they are having issues on RA post 1.9.5 as well. If they are than that could help the devs perhaps narrow down what happened.

I use crt emudriver. also using 1.12.0 No problems what soever

1 Like

Can you please post your Retroarch.cfg?

certainly. I can do that tomorrow (11/12)

1 Like

Ok. Can you tell me how to post my confog file? Im stoopid.

Thank you but the issue is fixed. Not sure what happened but I reinstalled CRT emudriver and the latest nightly works fine now with switcres. I have no idea why versions before 1.9.5 worked fine but whatever it works now.