CRT Switchres not quite feeling right on CRT arcade monitor

crt

#21

So vga out of the pc to hdmi? Have you tried the 31khz mode on your trisync?

I assume this setup works with groovymame?


#22

So it’s HDMI > VGA adaptor from the gfx card. It’s a dual sync monitor (15/24). I haven’t tried groovymame on Linux yet but it did work in windows yes (the issue in windows is likely I didn’t install all the modelines - I have another cab that I will try that on (that is the tri sync).

The Linux one is the dual sync. both using Radeon 7850 with active HDMI to VGA output.


#23

OK, so HDMI is not currently implemented in the Linux build! So that will be you main issue there. are you not able to use VGA/DVI?

You will need to go back to windows to use HDMI, sorry. As I said in one my previous post, make sure you edit the ini and add all the modelines. Dynamic modlines are not implemented so you need to install every mode you need.


#24

Haha ah I see fair enough. I don’t have a VGA to dvi adaptor handy I don’t think but I’ll have a look. Ill try adding the modelines on the second cab (it’s at my office so I will check in a couple hours) and if that works and I have no dvi/VGA adaptor I’ll switch back to windows. Thanks!

(I did find one but I’m assuming it’s not an active adaptor since I’m not getting any signal. Oh well)


#25

@Alphanu I believe we have the menu options set up for entering a custom prefix (e.g., HDMI, DP, etc.), we just need it hooked up.


#26

Yeah I did see. Only issue for me ATM is time. With work, uni and kids i don’t have 5 minutes to myself these day. However, I will get round to it soon :sunglasses:


#27

Heh, I know how it goes… no hurry :slight_smile:


#28

No go on the windows build. I’ve tried both native and super modelines and setting the desktop to 704x480. No matter what combination I use I’m just not making any progress :frowning:

-edit- Seems like it’s not installing the modelines correctly. Not sure why but even when it says it installs them (rejecting some really large ones that aren’t even in the ini like 5k and 7k??) only 640x480 seems to be available.

Well at least that’s given me a place to start.

-edit2- OK some progress at last. I need to restart after setting the modelines each time, then set CRT Switchres to 15khz rather than 31. This gives off a really high pitched whine that would likely turn me into a vegetable if I left it on for extended periods of time but at least I’m getting somewhere. Hopefully I can actually get the rest of the way so I don’t go crazy with that sound.

-edit3- I’m just going to buy a couple of DVI/VGA adapters, install linux on both and (hopefully) call it a day.


#29

Once you have the resolutions installed you can edit them with AcadeOSD. This will help get rid of the whistle.

Also when you install the resolutions, you can choose different presents for your CRT monitor type. So install them with a different preset.


#30

Thanks for all your help so far but unfortunately I feel like I’ve taken several steps backwards now. My Ubuntu experience so far has definitely been anything but plug and play. I just received my active DVI/VGA adaptor and can get a picture to display but I have to manually use xrandr to do this on every boot. That’s not feasible for an arcade machine build at all. There are many complicated methods online to get this to work on bootup each time but none work for me and it seems crazy I have to do this anyway. Sigh.

On top of that, I’m not getting anything out of retroarch at all. I feel like it’s likely due to me messing with the settings before, but I have no idea how to reset them now as I am very unfamiliar with the linux filesystem so don’t know where the retroarch folder is located.

Sorry, I’m pretty frustrated right now. I kind of want to just go back to Windows at this point (or just install GroovyArcade cause I’m really tired of dealing with this).


#31

In ubuntu, if you click on the 9 little dots in the bottom-left corner and type ‘startup’, it’ll suggest the ‘startup applications’ program, which lets you add programs/scripts/commands to run at startup. Nothing too crazy.

If you want to return to default retroarch settings, you just need to delete your retroarch.cfg, which lives in ~/.config/retroarch usually but if you installed the snap package, it’s in ~/snap/retroarch/current/.config/retroarch. (speaking of the snap package, I’m not sure whether it even has the right permissions for changing resolution/refresh rate…)

With all that said, you can certainly go back to Windows if you feel more comfortable with it. Linux has the aforementioned advantages including runtime modeline generation, but if you can’t make it work for you, that doesn’t really matter :slight_smile:


#32

Ah thanks. Well I have a setup on two hard drives now so I can dual boot. I’ll give ubuntu one last try and see how that goes. Thanks for being patient with me haha


#33

If you’re on Windows still it’s probably be easier to do this with EventGhost. You can set it up to trigger a resolution change when Retroarch comes to the forefront and revert to the original res when your front end becomes active again.


#34

I’m guessing you don’t have the right modline installed. I have a similar priblem when i try to load a rom i don’t have the right modline for. Have you tried loading another rom? Try loading a common Capcom game like street fighter 2


#35

So I think that you’re right. I seem to have managed to get it switching for some games (namely Capcom games only) but anything else just goes back to desktop resolution and so is squished.

I’m not sure how this is possible though. I’m installing the modelines from this page, and from what I can tell they are being installed correctly (at least in vmmaker). I’m running out of things to troubleshoot to be honest.

-edit- actually it’s actually only some games that don’t work (my test number was small but upon further expansion I’m finding more work than I expected).

Question I have no would be, how would I go about finding the correct modelines needed for the games that don’t work (my test case here is Hammerin Harry).

Thanks.


#36

You can google the game and what it’s native resolution is. I think there is a huge groovymame file out there with the resolution for most games. Important to know is that one superresolution can work for many native resolutions i. E. 2560x240 will work for 256x240 and 259x240. I can post the resolutions I’m using if you like.