CRT Switchres not quite feeling right on CRT arcade monitor

crt

#41

Your welcome. Get u sum hammering harry


#42

Hi!

Anyone knows why mastersystem is mapped at 2560x200? I think core is 256x192…

Thx!


#43

Most GPUs can’t go below 200 lines, so Master System is padded up to that. You should be able to run it in integer scale with borders, I think. I’m not sure why it’s mapped to a super resolution but it shouldn’t hurt anything anyway.


#44

Thx @hunterk. The difference mastersystem with retroarch and groovymame are borders, i activated in core options and it’s ok.

Another question, ¿it’s possible to run reicast at 640x240p? I don’t see it in options, i think it’s the better resolution for a tv crt (640x480i to much and 320x240 to low…)

Thx!


#45

The native resolution for most games on the dreamcast was 480i. I’m sure tgere were a few 240p games. But the core has the resolution locked @480i ATM

If we can get a list of games together that are defiantly 240p we can create an issue on Github and have 240p internal resolution added. It maybe the case that it already is so well need to test these games too.


#46

Thank you very much @Alphanu

I tested 320x240p on core options and it’s more arcade feeling but 640x240p it’s better on my experience running demul or pcsx2 for example.

Nice work with retroarch crt.


#47

How exactly do you select to use native res switching instead of super resolutions? I’m using Windows 10, with a lot of native resolutions modelines already installed and it’s not clear to me how to choose native res instead of super res.


#48

In the CRT switch menu options. You can change between native, 1920, 2560 and 3840


#49

The only option available in the latest Retroarch version about CRT SwitchRes inside the video settings menu is “Use Custom Refresh Rate”. Am I missing something? Do I need to directly edit the retroarch.cfg file?

If so, which option bellow do I need to change to allow native resolutions switch only?

crt_switch_center_adjust = “0” crt_switch_resolution = “0” crt_switch_resolution_super = “2560” crt_switch_resolution_use_custom_refresh_rate = “false” crt_video_refresh_rate = “59.940060”

EDIT: I turned on “Show Advanced Settings” and now I can see what you are talking about. I will give a try… Thanks.


#50

It should be. I’m running super resolution, but after I load a Dreamcast game, I go into Settings>Video>Resolution and there’s a list of modelines you have installed. Then you can pick the 240p one.

It’s not an ideal ‘final’ solutions as it’s manual, but you can play DC games at 240p that way. Capcom vs. SNK looks amazing :smiley:


#51

Thx! but custom aspect ratio height still’s at 480(1x)…i don’t know how do you change that without affect scaling…if i change to native my crt sync out…

My alternative is use redream with 640x240 desktop resolution and it’s fine, but i prefer retroarch if it’s possible.


#52

I’m also interested in this, but what I do at this moment is just resizing vertically, it’s like half a super-sampling anti-aliasing(?). The quickest and easiest way to do it is to use reicast resolution: 640x480, screen resolution: 640x240 and bilinear. glslp, at that screen resolution, that shader won’t blur horizontally.


#53

It sounds like you have a slightly different configuration than me. I would use Core Provided or 4:3 for the aspect ratio to get my method to work. Custom isn’t going to let you go lower than 1x.