CRT SwitchRes not working unless desktop is progressive

Hi all, I’m hoping to get some help on getting SwitchRes to do its thing properly with an interlaced desktop set to 640x480.

I’ve been chiming in on other threads here and here on SwitchRes, it’s an awesome feature that should really get more attention.

For some reason, I can’t get it to work properly unless my desktop is set to a progressive resolution, anything other than 320x240p or 2560x240p gives me interlacing in RetroArch. The real trouble is LaunchBox Big Box looks barely legible at 320x240p and having a super resolution desktop would make it unusable with the stretching.

I’m using all the recommended super resolutions in the documentation + the Groovymame modelines (120 in all). My settings are SwitchRes 2560 with Integer Scaling set to ‘On’. I’ve tried fiddling with these and other Video settings (e.g. changing video drivers) with no luck.

Any ideas what to do? I’ve seen other users post here with the same issues. It seems like this is a fundamental bug with SwitchRes.

I’m happy to help document/diagnose anything to help other folks out there with the same issue, thanks!

Bumpity bump bump? @alphanu :slight_smile:

Same here…If my desktop is interlaced, switchres will work once to the correct progressive…

If I try another game without quitting RA I get an interlaced picture too.

I want an interlaced desktop because I run a front end on my CRT and the box art looks like crap on progressive and yes the text is eligible.