Current MAME core not running games

Yeah, non-merged is the best solution for those who don’t want the full set and only want to keep a smaller collection of individual games.

I guess I’ll be back once I know if I have a continued problem, then. Which will be ages since this download is only moving at 1/10th my download speed and estimated to take a full day.

While you are at it, you can try finding an updated samples set. These count as “MAME extras” along with things like artwork, cheats, history dat, snapshots, etc.

The samples though are needed for some older games to have complete sound. The reason these are kept as sound samples and not as roms is for authenticity.

The “samples” folder should be in the system/mame folder if you are using RetroArch.

If I put my ROMs on the Arcade folder later, should the sample folder stay in the MAME folder or be moved to the Arcade folder?

My trustworthy source has a “MAME Support Files” pack that includes a Samples folder, among many others.

Samples are in a separate folder. You don’t have to move them. You can put the romset wherever you want i guess (as long as every file is in there).

In the standalone mame you can change the paths for other things as well. I suppose you can do that in Retroarch too. But i never bothered with it. I have my roms in a folder of my choosing and everything else, like the samples, are in their default folders since i never needed them elsewhere.

A CPS-2 romset meant for mame2016 (0.174) can’t work with current mame, because it lacks the encryption key added in 0.178.

Read the arcade documentation before reporting issues with arcade emulation.

Its not just CPS2 games, the game I used for the logs just happened to be one(mainly as its one I played a lot so it was the first I noticed). Games such as Gorf were presenting the same issue.

Which is another bad example, you say it works in mame2010, but back then the sound wasn’t properly emulated so i don’t think the bios for the sound board ( was required, it is now.

Work on fixing your romsets and bioses, only afterward should you be posting here, with logs.

Okay, the rudeness is 100% not necessary.

Particularly when it has already been made clear that I am doing exactly what you’re getting on me to do.

1 Like

Telling you to use the right romsets and bioses for the arcade emulator you are using is rude ? Telling you to provide logs is rude ? Telling you to read a documentation is rude ?

The only thing that has been made clear is that you aren’t using the romsets matching your arcade emulator version. The cps2 romset from 2016 has been proving this, the romset that previously didn’t need a bios for its sound board too.

The rudeness comes from your tone in re-stating what was already made clear.

If you believe that “the only thing that has been made clear” is that I was using the wrong ROMset, then you didn’t read the entire thread before posting. I had already made clear that I am in the process of acquiring the appropriate ROMset before your first post.

Maybe you shouldn’t talk about rudeness when you come reporting issues without following the guidelines from our documentation.

And no, there is nothing inappropriate in posts telling you should read the documentation before reporting issues and/or explaining in details why your romset won’t load, so stop flagging them.

I’ll close. Reopening at the condition it stops being meaninglessly heated.

Acceptable, and I will admit that I did not respond properly to the perceived rudeness myself. I apologize for this.

Since I am still awaiting the download of the ROMs to be complete(it’s moving faster but I’m suddenly having problems with my Torrent client that are slowing it), it will be a while before I have any updates to post, but it is best to keep the thread open until we know if the “apparent” problem is the actual problem.

A friend of mine was able to direct me to a non-merged ROMset from a “trustworthy” source, which will be done sooner, so I can test a merged and non-merged ROMset.

(I put the “trustworthy” in quotes because while I can trust the source not to put any malware on my PC I can’t automatically trust the set to be properly updated since the source isn’t exactly a place dedicated to game preservation, or even gaming content primarily)

You should be able to test the non-merged set if some files (and not the whole torrent) are complete.

The point of that set is that each file/game has all the required files it needs to run (bios included) and doesn’t depend on separate files in the folder. You could also pick and choose only the roms you want. So if a file is complete, you can copy it in your roms folder and test it.

Also, what do you mean by “properly updated”? You aren’t sure its a 0.244 set? Because that would defeat the purpose of downloading it. If its an old set it will be a crapshoot if a game works or not.

Call me excessive in my thoroughness if you wish, but all things considered since I need to update the whole set anyway I might as well grab the whole thing regardless.

Nonetheless, earlier on I DID copy over and test Gorf alone, and got the same result as what brought this thread about to begin with. But I wanted to make sure I cover EVERYTHING before I posted so I have as much information to provide as possible.

The non-merged set is being transferred over to my arcade PC as I type this. Once finished I will check things more thoroughly, and let you know what came up.

The merged set is still transferring - I solved the issues that had cropped up with my Torrent client(a background update to Malwarebytes caused it to start blocking the program), so I’ve only got the source transfer rates to worry about.

My concern is that it CLAIMS to be a 244 set, but the source is not a place dedicated to accurate preservation of…anything, let alone video games in particular, so I have no way of knowing if it’s an accurate pack of ROMs, or just an old one relabeled, or an attempt to update an older pack that was done incorrectly.

You can always validate your set using a DAT from the latest MAME and ClrMamePro or similar.

1 Like

The non-merged set SEEMS to be working - I’ve had a few CPS2 games, specifically Marvel vs Capcom, Super Street Fighter II(though NOT Super Street Fighter II TURBO, oddly), and Street Fighter III 3rd Strike, crash Retroarch on loading, with no log file being left behind.

Aside from that every game I knew to be having an issue, like Gorf, Bloody Roar, and Vampire Savior, are now functioning as they should be. I’m also having a minor button mapping issue, but I should be able to work it out on my own. The mystery is now limited to these crashes.

I should probably wait until we figure this out before I start trimming the ROMs down to just what I want.

EDIT: Oops - forgot SF3 Third Strike is CPS-3, not 2. Still, the crashes occur in the same way.

Uninstalled/reinstalled Retroarch to cover all bases. Crashing of aforementioned games has ceased. Glitch during installation?

1 Like