Daphne + RetroArch (Help Please)

Hi, I’m currently struggling with running Daphne (https://github.com/libretro/daphne) with RA. I think the only thing that I’m not getting right is how the ZIP-Files for the Roms need to be structured. I see that there is some advice on how to do that in the Docs. (Link above) but i always get the error unable to open content… So if anybody knows on how to exactly the ZIP file for a game (lets say for example Dragons Lair which i could download with Daphne loader, no problem) has to be set up i would be very thankful!

I also would like to know setup structure for Daphne. Is there a tutorial available some where to setup this core with windows 10?

1 Like

I am also interested.

1 Like

I’m also interested to integrate this core into lakka system :slight_smile:

1 Like

So no one knows how?

1 Like

Still couldn’t figure it out: i’ve tried all combinations of files and folders that could make sense but just cant figure out what the dev meant by that:

|pics:|[home_dir]/pics| |ram:|[home_dir]/ram| |sound:|[home_dir]/sound| |framefile:|[home_dir]/framefile| |CDROM:|[framefile_dir]/[first line in the framefile (IE lair.txt)]|

I am also very interested in getting this core to work :slight_smile:

1 Like

Ok i got it to work at least partially:

  1. Just follow this tutorial for all the daphne stuff: https://www.youtube.com/watch?v=wh17Nr3GRnA

  2. NOW THE IMPORTANT PART: (example is lair.zip)

a. goto folder: “vldp_dl” in the daphne folder. copy lair.txt in the the framefile folder in the daphne folder.

b. open lair.txt. remove the first line that just says “.” and paste the absolute path to the lair.m2v file into the first line of the text-file. so that your text file looks for example like this:


151 lair.m2v

  1. In Retroarch just select the lair.zip file that is in the roms folder in the daphne and run it.

  2. Problems: 1. No sound, 2. cant remap the controls (emulator crashes each time). If anybody knows how to fix this issues i would be thankful.

I know tha´s an old topic, but I wasn´t able to get Daphne to work till now. I read a lot of forums and nothing.

I could make some games loading, but the ones I could are all with no sound. I alread checked the logs and nothing. On Daphne libreto log, the message “Initializing Sound System …” appears, but following it there is no sound system being activated. On Daphne standalone, the log shows the sound system activated.

I already changed the drivers, checked the retroarch log and nothing.

Any help is welcome.

I’m guessing this core isn’t yet ready for prime time. I’ve tested on OSX and Windows with little to no success.

As far as how it should work, here’s what I’ve found. Your folder structure should be approximately as follows:

The frame file should have the following info in it:

151	lair.m2v

The key being that the first line points to the path of the game folder relative to the framefile (or is the absolute path to the game folder). The game folder or game files could be really anywhere, including in the same folder as the framefile, so long as the first line points to where they are you should be good to go. The second line points to the video file and the frame to start from. More info on the framefile here.

When I launch lair.zip in Retroarch on OSX it crashes immediately with a segfault. On Windows the game starts but is a glitchy mess and there is no audio.

After attempting either of these, the core will generate a daphne_log.txt in the games home directory, which includes the daphne command line used to launch the game, and some info on the framefile and game files if they’re found (which tells you the core found the right files):

--DAPHNE version 1.0.7
--Command line is: daphne lair vldp -framefile lair.txt -fullscreen -seek_frames_per_ms 20 -min_seek_delay 1000 -fastboot -cheat -useoverlaysb 0 -homedir /path_to_game/Dragons_Lair/roms/.. 
Setting alternate home dir:
Framefile parse succeeded. Video Audio directory is: /path_to_game/Dragons_Lair/roms/../framefile/../cdrom/lair/

If I use native daphne and the same command line listed in the daphne_log.txt above, then the game will launch with video and audio (so at least I know the file structure is good).

Sorry for the delay answering you.

First, thanks a lot for your explanation. I have done everything you mention before with the same result. I´m moving to standalone Daphne, but I´m facing some problems when the game loads in fullscreen. The problem is that the sound vanishes when fullscreen

Is this core working nowadays?

hi i wonder will it be a daphne core for pc i future if so i hope so

This looks like it may be a route for Daphne and Singe!!!