Dekstop Refresh Rate!


RetroArch seems to change my desktop it refresh rate to lower values, each time i load the app/core !! This only happends when going in fullscreen mode though!

I disabled the setting “switch refresh rate automatically”, but it doesn’t apply !? I also, set custom refresh rate to 165hz wich is my desktop refresh all the time, but doesn’t work aswell !?

I mean , all these options and retroARch still doesn’t comply !!

And the problem is that it doesn"t revert it back to previous settings once closed !!

Is there an way to prevent retroarch to alter my desktops refresh rate, wich is 165hz ?

Even though i turned off the autochange setting in RetroArch , it keeps altering my desktop its refresh rate back to 60hz !!

I have had this kind of behaviour with pscx2 emu aswell.
And the only sollution to prevent the emu from altering my desktop refresh rate during gaming, wos to add the app to my amd center and enable and use → RSR (Radeon Super Resolution ) fullscreen borderless …

Only that ↑ prevented the emu from changing the refresh rate all the time !!

much obliged, TD

That seems to be some kind of driver related thing with VRR displays, and switching to d3d11 supposedly stops it from happening.

Somebody with such hardware should inspect why RA is not able to stop that from happening with all drivers. The autoswitch option follows only core offered refresh rate, and RA itself only changes to video_refresh_rate if using non-windowed fullscreen.

What do you mean by “RA” ?

It’s annoying to have to revert it back always… Also, keeping displays max refresh rate results in butter butt smooth fluid gameplay in pcsx2 i’d say :smiley: :ok_hand:

Way better than playing at 60hz, and NO A/V sync problems either … pitch perfect smooth playback … so, why changing the monitors/tv refresh rate is beyond me !

cheers, TD

Ooh! I know that one! It’s RetroArch! :grinning:

And you do it so well :smirk:

No, i thought onnion wos reffering to an Radeon setting of mine, since i mentiond some Radeon settings in my initial post :neutral_face:

RA easily could be, Radeon Afterburner :crazy_face:

I have to give it to you DRybone… you should play Wordle every day atleast once :smirk: :ok_hand:

cheers TD

Update to my previous inquiry :

So, appearantly i have to rely on Radeons “RSR” feature ONCE AGAIN and use Fullscreen Borderless to prevent “RA” :smirk: from changing desktops resolution… Just like it wos the case with pcsx2 back then !!!

To anyone who has an capable RSR gpu… ← this is the fix/work arround to keep your desktops refresh rate all times …

And i very much like what i see ingame too :grin: :ok_hand: … Not only ps2 emu runs smooth, but even 2D psx games like alundra, are noticeable butter BUTT cheeks smooth … … Delightfull :yum:

Cheers, TD

It happens with my nvidia card as well. I have it set to use my desktop refresh rate (also 165), even in the nvidia control panel, but it always seems to be playing at 60. Not sure how to fix it.

Does your nvidia has upscale methods/features for apps/games?

That’s the only way i could work arround it , by adding RA to my radeon command center. And use the RSR feature … Wich is actually an upscale technique to atleast maintain games fps at higher resolutions or even improve fps …

well , thats the general idea…

cheers, TD