Dolphin core crashes when I boot a game!

hi! i follow the wiki and set the sys folder in retroarch/system/dolphin-emu and the core informations says that dolphin sys is still missing…i also tried the solution of moveit124 but the issue is still here…having an idea?

Enough people are experiencing this that something must be up. I’m not able to reproduce it on my end, so it may be Windows-only, in which case it could be a problem with parsing paths/names. I’m not sure right now, but I’m investigating.

@asvarath It will always say that error, I think this has to do with that its trying to locate the “Sys” folder in multiple locations, and even if it finds it in one it doesnt find it in the other and gives that error. I wrote a bigger post on possible fixes to issues but I will say the Dolphin Core just seems to be riddled with bugs and problems for certain games.

Sys folder placed into retroarch/system/dolphin-emu makes some roms crash instantly, just saying, maybe i can help with this (So Retroarch does recognise that path despite telling you that the folder is missing). For example i was trying to run Baten Kaitos for GameCube, crash everytime. Then i deleted that folder and now it loads without problems (User folder into saves is harmless instead, and will be reacreated, if you deleted it, everytime you load a rom). And if i add Sys folder content to User folder content, CRASH happens again. So the problem is definitely something inside Sys folder, i’ll try every file inside it to isolate the problem.

EDIT: yeah ok i found out the problem in my case, it was a string inside GKB.ini (GameSettings folder) related to Baten Kaitos: CPUThread = 0

After deleting this no more crashes. So, if some games are crashing on load, search in GameSettings folder some strings related to them. Or simply delete GameSettings folder.

Tested on vulkan driver and Windows 7.

1 Like

About Eternal Darkness, i faced the exact same problems moveit124 described, so far i know these things:

The crash after the first screen is caused by missing this file and string:

Sys/GameSettings/GED.ini

[Core]

#Values set here will override the main Dolphin settings.

GPUDeterminismMode = fake-completion

So, restoring this, it’s able to run. Problem is that this rom constantly suffers of random freezes, probably driver or launcher related. Also, Dolphin will crash at every second rom you load, no matter what.

Just found my way here after Baten Kaitos insta gibbed retroarch. Thought my image might be borked but Dolphin standalone handled it fine.

Removing the CPUThread = 0 as EXDuelist suggested does fix it, just hoping it doesnt introduce issues elsewhere.

Is there no other fix?

I just redid all the folders with fresh updated copies to no avail. Apparently whoever maintains the RA dolphin core has to bake in game specific fixes i presume?

FWIW @Exdualist, eternal darkness loads fine for me. Didnt start a game but it runs up to the start screen with np at least. Also no problem running a second/multiple roms in a row.

Just the Baten Kaitos eternal wings issue still present if you dont edit out that file.

I’m having the same issue as OP. I just started to toy around with RetroArch yesterday, so I’m still getting the hang of it. I’ve gotten NES, SNES, Gameboy/Color, GBA, N64, and PSX games to work, although the latter took a bit of tinkering. But the Dolphin core I’m using doesn’t read any games, zipped or not. The ISO files are read just fine by Dolphin without RetroArch, however. I’m using RetroArch v1.7.8 if that helps.

I’ve tried what moveit124 suggested and I tried changing the video drivers, but neither fixed the problem.

Hi, downloaded a fresh copy of Retroarch 1.8 and Dolphin core make crash retroarch. It only happens with this core, all other cores work fine.

I was using this core since months, but now it’s impossible to play with it.

Any suggestions?

https://github.com/libretro/dolphin/issues/124

It might be what you are experiencing. Hopefully it can be fixed soonish.

Hi DJoneK, yes this is exactly my problem.

When you try to run the core with gl driver Retroarch crash.

I can’t seem to play any Wii or Gamecube games… I had paper mario 2 working yesterday but it would freeze before getting anywhere noteworthy in the game (before the first battle)

Anyone have any help on this? I am on a macOS system if that matters…

Also anyone know why my games all say “Game has no achievements” … I followed the instructions to set up RetroAchievements but all my games say they don’t have achievements even though I see on the website RetroAchievements.Org that they do?

Crashes on GL Core but work fine on GLCORE Video Plugin

I can not speak for a Mac, but I did find something interesting. On a Shield TV, GameCube games would crash, but Wii games worked. Reinstalled 64 bit 1.8.1 RA. Downloaded the dolphin master zip. It extracted in a “user” folder in “saves.” To be safe, extracted the sys folder from dolphin-master and placed it into a folder “dolphin-emu” in the RA system folder. Enabled share context and disabled allow core to change video drivers in core settings.

Loaded the GameCube/Wii core. GameCube crashed several times. Loaded a Wii game and it started. Went into the quick menu options and disabled “fastmem.” Saved the core settings in the override settings. Exited RA, reloaded RA and the Dolphin core. Loaded Methane Bros. and the game loaded and ran. Tested several other GameCube games. All ran, very slowly and with garbled sound. Turned fastmem back on, saved the core settings again in the override tab. Exited RA, reloaded RA and the Dolphin core. Tried to play Methane Bros. and the core crashed. Loaded another Wii game to access the quick settings again to turn off fastmem. Repeated core save procedure as above and the GameCube games loaded and played.

It seems like for the Android Pie on the Shield TV that fastmem is having an effect on whether GameCube games can run. There are some postings I have seen that mention this as well.

I hope this helps others that may have issues as well.

1 Like

Good info! Thanks for sharing it!

I had the same issue! I am on a windows 10 machine Specs: Intel i5-9600k RTX 2070 Super 16gb ram 500gb ssd

I was able to have all cores functioning on retroArch except GameCube.

When running gamecube games i have to go to settings -> Core -> enable hardware shared context and disable “Allow cores to switch from video driver” in order to see the core option in the menu out must first go to settings-> user interface -> enable advanced settings

Seems like the main issue is with the dolphin core and the Gl graphics driver so it tries to switch off of it? not sure but this fixed the issue for me

1 Like