Dolphin Crashes When Set To Vulkan

Hey, guys. I recently built a new PC, and I’m trying to get RetroArch up and running. I tried multiple times loading up a GameCube game, and it repeatedly crashed on me. My default config has Vulkan set at the driver, but I have another with OpenGL I keep on hand for certain cores. When I tried loading with this config, everything was fine. But it’s my understanding Vulkan is the preferred way to run the Dolphin core. Here’s a copy of my log. I’m hoping someone smarter than me can tell me where my problem lies. I suspect it might have something to do with the shader.

Do you have rewind/runahead enabled? if so, turn it/them off. Also, you might try d3d11 video driver.

2 Likes

I did have runahead enabled. You’ve solved yet another one of my issues. Thanks again, hunterk!

2 Likes

I’m having this same problem, but I do not have Run Ahead or Rewind enabled… Any other possibilities?

I have the same problem, also with runahead disabled. Other cores work fine with Vulkan, except this one. I’m running Ubuntu 20.04 with a Tonga Radeon R9 380. I’ve tried with the options Hardware Shared Context etc but all I do results in an instant crash. OpenGL works fine. Anything else I can try?

Do you have threaded video enabled? it seems to be problematic with some drivers in linux. Otherwise, can you pastebin a log of it crashing for you with vulkan? (I’m assuming other cores work okay for you with vulkan?)

thx for your reply. no, I have threaded video disabled.

Here is my log: https://privatebin.net/?f1728a19db6095e6#5nY4QMNwwM3YTVEC3QnWC2GmRwSEARmkBSJgDgze2bUE

Can you try going to settings > core (this is an advanced setting, so you’ll need to go to settings > user interface > show advanced settings ON first) and set “allow cores to change the video driver” OFF?

The last thing that might be causing issues that I noticed would be using windowed/borderless fullscreen. You might need to disabled that in settings > video > fullscreen mode.

Tried, but also didn’t work. Noticed that n64 also doesn’t work, at least it gives more specific feedback in the log:

https://privatebin.net/?6e9fec1b868210b4#5c1zPXyTSnDawnajFxQk4vgvBqUshC94s7B3JoXxofaY

might this all not work because I’ve compiled Retroarch myself and forgot to set a configure flag or something?

It appears it was compiled without OpenGL support, which is a problem for mupen, at least until you can get in there and change some options for it to not need it. That is, the default gfx plugin is GLideN64, while you would need ParaLLEl-RDP or Angrylion for vulkan. It’s supposed to have some intelligent fallback routines, but I don’t see those happening in the log, so perhaps something is amiss there.

What about software-rendered cores? are they working for you?