Dolphine Not Loading Games Linux Mint 20.1

I had LM 19 for a while and was able to use Dolphin for NGCube and Wii games, but I have recently upgraded to LM 20.1. I had to reinstall RetroArch and with no problem, using the FlatPack to because it is the updated version.

After accessing RetroArch, then loading Dolphin core and then accessing a GameCube game, it states there is NO ITEMS.

Extra piece of info. I have all my ROM’s on another internal HDD. All ROM’s are in a separated folder for each type of system. NES, SNES, N64 and so forth. So I know how to navigate pretty easily.

Two things I need to know which I have not found on these forums.

  1. How to fix this issue
  2. How to uninstall a Core like Dolphin to reinstall it to see if that’ll do the trick. I have not been able to find a Topic that revolves around Linux to uninstall/remove a core. Sorry if I did miss that though.

Please and thank you for all your help. I read a lot of topics already and you all are great help, especially with so many OS’s, Distro’s and platforms.

UPDATE: I installed Dolphin on the LM 20.1 Software Manager FlatPack. I was able to get it working and a game. Does not play sound, haven’t figured out the settings yet. How ever, is there a weird connection then?

I’m not sure how to fix your issue, unfortunately, but if you can post a log of you trying and failing to load the core/content, that might give an indication of what’s going on.

To uninstall a core, you can usually just delete the core library. You can also go to settings > core > manage and delete them from there.

1 Like


I’m trying to make dolphin work on linux too and the core fails to load. Here is my log file:

Thank you

1 Like

Error(s): cannot open shared object file: No such file or directory

How is your RetroArch installed? a universal package (snap/flatpak/appimage)? something else?

Flatpak, but will try the community version, and check if I get same error. I have that libusb packages in my pc and my gamepad is identified and configured correctly out of the box.

The universal packages typically need the libs included in the package itself, AFAIK, as they generally don’t have any mechanism for falling back to system libs (appimage might, though, since it doesn’t try to sandbox anything).

I have now installed Retroarch from package manager community repository, and I think that the core loads now. But Retroarch crashes after that. [ERROR] [Wayland]: Failed to connect to Wayland server. This error have appeared before with the sandbox installation, but I guess because the core failed to load it didn’t crashed Retroarch. Full log:

I don’t think the wayland error is a real error and can be safely ignored. I’m not sure what’s the root of your issue, unfortunately. The usual suspects are video driver–though it looks like you’re already using vulkan, right?–rewind or runahead (both of which cause dolphin to crash instantly).

Thanks anyway for helping, I have installed now from your snap and everything works fine, but dolphin keep failing to load core. Now it’s some "Error(s): /snap/retroarch/423/usr/lib/x86_64-linux-gnu/ version `GLIBCXX_3.4.26’ not found ". Yes Iḿ using vulkan tried, some different settings and I’ll going to look forward to possible fixes in next versions. I’m running it on Manjaro, maybe if I was using ubuntu or similar distro would have more luck to get all my retrogaming in one place and with all amazing features RA have. But again thanks for your time, very appreciated.

1 Like

Yes, the snap package definitely has the GLIBC mismatch, which should correct itself in a couple of months when snaps are no longer built with Xenial (our buildbot uses Bionic, which is the source of the mismatch).


Hi, i’m having the exact same problems as zepipoca! I’m on KDE Neon (based on Ubuntu 20.4).

The Flatpak version of RetroArch tells me:

Error(s): cannot open shared object file: No such file or directory

When trying to open a Dolphin game.

I tried installing the Snap version, which gives me the other error:

GLIBCXX_3.4.26 not found

@hunterk Is there a solution to fix this, or do we have to wait a couple of months like you said? Thanks

Nevermind, the got it working by installing the native Ubuntu package. However it still does not load the game. It loads a black screen and then closes Retroarch. But this is another problem for another thread maybe

I am having the same issue. In my case, I am using the standalone version, and it crashes as soon as I load a game with Vulkan. Using GL, it works after you wait a while, and Glcore works alright. I want to use Vulkan, though.

Here’s my log: