Download Core and Core Updater do NOTHING

Raspberry Pi 3 ArchlinuxArm Retroarch from the ArchlinuxArm repositories…

All the posts I have found that are similar to this are all focussed on the cores not installing because of permissions in the default directories when using Archlinux. This appears to be different…

It’s not that cores fail to download or fail to extract… With this particular installation, when I select “download Core” or “Update Cores”, the screen just flashes once, and then does absolutely nothing… The menu doesn’t change, it doesn’t give me any options for picking anything, it just flashes one time and does nothing.

I have installed and ran Retroarch on Archlinux a small handful of times and have never seen this happen. This is the first time I have tried it on a Pi, though, and with with ArchlinuxArm.


i have same problem did you find a solution?

Check your config and make sure that the core location is set to somewhere that you have write access to.

1 Like

Can someone please help me figure out how to get my retro gaming up to speed cuz I think I got the new software but my screen is still in the old formate

I’m not sure what you mean by that. If you mean it’s just a black screen with blocky white text, that means it can’t find the assets, so make sure in settings > directory that your assets directory is set to something sensible that you have write-permissions to and then go to the online updater and (re)download the assets.

1 Like

Sorry for the long delay. I honestly forgot that I had posted this. I DID find the solution after chatting with a few of the devs on IRC. This wasn’t a permissions thing, but actually an issue with the config file that comes with the Archlinux package from their repos. The URL was wrong and therefore the online updater was not able to find anything, causing the interface to “litterally” do nothing when I tried to select “download cores” or anything else involving the internet. I had to change the URL to something sensible for my system…… you get the idea.

There were other issues in the stock archlinux config as well, but I believe our devs were going to push to get that corrected. I can post my (now working) config, if somebody needs it.

Yes. I just posted it below. (pending approval)

Great sugestion! That helps to solve my problem. Cheers hunterk!> Blockquote

I am new here - and see this post from a ways, back. I too have the issue with trying to update retroarch from 1.7.6 to 1.8.5. The screen just flashes. Be gentle, but I am not sure how to change the directory, to a writable location, or fix this? The cause of all this is that I am having an issue where I can’t two joysticks to work in the same emulator at the same time. This used to work on other builds I had, but not this one. The two joysticks are a Tankstick and an 8 button joystick. But no pair of joysticks works, so I m not sure it’s the Tankstick.

So I realize I may have two separate issues here, but the big one is I’d love to update RetroArch to 1.8.5. Thoughts?

Hi Vile - just curious how you fixed? I am new to this so a bit limited in getting context. How did you change the URL? To what, and how did that work?

are you using 32bit version? seems like builbot for linux x86 is not creating files. check yourself:

how we can report this for fix?

No, I was using arm.

Go to settings> network > updater > and change the Buildbot Cores URL

1 Like

I’ve installed RetroArch 1.9.14 using Snap Package on Elementary OS 6.1 Odin. When I go to Main Menu > Online Updater > Core Downloader,

I get “Fetching Core list” and it will then show “No Entries to Display”

When I go to Settings > Directory > Cores,the default directory is: /home//snap/retroarch/1005/.config/retroarch

However when I browse the path in the file browser .config/retroarch does not exist under /home//snap/retroarch/1005/

Is this what is preventing me from downloading cores in retroarch?

Also in Settings > Network > Updater, the default URL is