DS4 Controller not working Wirelessly

Hi! After not using RetroArch for a couple of months, I recently returned and have been having issues with my DS4 controller. I’ll try my best to describe the behaviour I’ve noticed.

  • The controller will not respond in RetroArch when connected wirelessly through bluetooth.
  • The controller will be detected as a Wireless Controller (or Dualshock 4 Controller if AutoConfigs are downloaded).
  • When plugged in with a USB cable, the controller works fine.
  • When plugged in with a USB cable, two controllers are detected. Only one of them working.
  • Other programs recognize the controllers inputs without any issues over wireless.
  • If I use a program such as DS4-Windows to emulate it being an XBox controller, two controllers are again detected, one as ‘Wireless Controller’ and one as a 360 controller. The 360 controller works, the wireless doesn’t.
  • Deleting retroarch.cfg doesn’t change anything.
  • Changing the input driver doesn’t change anything.
  • Whether they controllers have AutoConfigs or not doesn’t matter.

I’ve been messing with this for hours now, but I’m totally lost, does anyone have any ideas? This worked fine 4 months or so ago. I’m running 1.9.0.

Any help is appreciated!

If all else fails, make an RA shortcut in steam and run it through there. Steam’s wireless controller support is really good.

I can confirm this problem exists on 1.9.1 as well. I have tried various things and I’m running out of ideas. Retroarch worked fine in 1.9.0, and now that I updated to 1.9.1, I can’t get anything to work, and I have tried uninstalling and reinstalling Retroarch, doing the same for DS4 Windows and it’s associated programs, and the stuff the OP said, and nothing works.