DS4 Controllers Not Mapped Properly

I have had my Xbox One controllers setup and working for quite some time now. For Christmas I got a coupld PS4 controllers which I am thrilled about because I want the 6 axis support for various games that use it.

I installed DS4Windows and got it connected to the PC. I also noticed in Joy2Key that all of my buttons were mapped properly already because DS4Windows emulates a 360 pad. So my profiles for Hyperspin, RocketLauncher (Pause Menu), and default profiles are working flawlessly.

The problem comes when I launch a game. The controls were for some emulators (Dolphin stand alone) but not for RA. I would truly appreciate some help.

Happy holidays :slight_smile:

FWIW, I updated Retroarch last week and noticed my 2 DS4’s stopped working correctly for me in some cores even though RA sees my controllers via the OSD messages. I too use DS4windows.

When I went to settings, input, I noticed it said “DualShock 4” for players 1 & 2. I changed it to “Xinput controller” or “Xboxone controller” and everything worked.

I don’t know if this is the same problem you’re having but sounds similar. RA is seeing the DS4 instead of the emulated Xbox controller.

2 Likes

That was the problem. Do you know if there is an easier way to fix this? I have about 60 systems setup. Perhaps a way to always force xinput? I’m trying to make my setup compatible with on the fly swapping between xbox one and ds4 controllers.

Also, my 6 axis doesn’t seem to be working properly. Have you had any issues with this? I considered buying one of Sony’s PS4 dongles but say Mayflash has one also. I use their Dolphin bar with no problems and that may be the way to go for 100% compatibility.

I can’t help you with the six axis part as I’ve never tried using it in RA. Maybe someone else could chime in.

What I ended up doing is launching each system in Rlauncher because I have matching system name RA configs and switching it to Xinput then saving the config; that seemed to fix things.

But with 60 systems you would have to save one, find the text line noting the input change then use notepad ++ to find and replace in multiple files.

Can I ask why you want to change between the 2 on the fly in RA? I ditched my XBone controllers as the dpads started to stick on them and was having massive connectivity issues with the wireless receiver for Windows.

Zero issues with the DS4’s and it’s been proven they have the lower rf input polling lag of any controller for the PC.

Well, when I was messing with this earlier today I looked in the config and saw input_driver = “dinput” When I changed it to xinput within the Input menu via F1 and looked at the saved config it still said dinput so I am a little confused by this.

I want to switch between the controllers because some people prefer the xbox pads since they are a little bigger. Some prefer the older style of the DS4 pad with the dpad in the upper left.

Check out a device called “CronusMax”. https://cronusmax.com

It eliminates the need for software drivers for the PS3/PS4/WiiMore, etc. It even lets you use a DualShock 3/4 controller on an Xbox, and use an Xbox 360/one controller on a Playstation 3/4, etc. Uses the controllers in Wired mode out-of-box, but add a bluetooth or Xbox RF dongle to the mix, and you can go wireless! Also can program macros to buttons, configure stutter fire/rapid fire, without having to open your controller or void your warranty.

I have an older model of it, and really only use the cross-platform functions, not the macros. I don’t play the newer systems much, but I do repair consoles, and it is sooo much easier to just carry one or two controllers around for testing systems, than to try to carry everything.

(I should say I don’t play newer games, not newer systems. I have both a PS3 and a PS Vita - but only for running RetroArch…)

“You can use as many controllers as the console allows, however you can use one controller per CronusMAX at any one time.”

That doesn’t seem like a very good option, but I appreciate your suggestion. MayFlash, the makers of the Dolphin Bar have one as well that I was considering. I also considered the actual Sony PS4 dongle.

I don’t understand why the text in the config isn’t changing but I guess that doesn’t matter as long as it’s working properly. I also actually got the 6 axis working using a DS4Windows patch. I also patched Cemu for motion controls. So I guess this thread can be considered solved.

Thanks again @trnzaddict for telling me about that RA controller config.