Dumping my own PS1 BIOS


#1

Hi,

I’ve dumped the PS1 Bios from my PSP. I don’t know if there is any use of it here. Anyway, here’s the dump info:

Title	SCPHXXXX.bin
CRC32	cc82b93b
MD5	32c04484c234fd09d79625e9fe2ec232
SHA-1	b8c96eefcaedd3f8ae2a58d71671364703caaa25
Size	524288
Dump method
	PSP3004 with CFW (6.61 PRO-C2_22-01-2015)
	Dumper BIOS 2.6
	VMP2MCR
	BIOSmerge 0.2
Dump date	07-Apr-2019

What is interesting is that when I run BIOS dumper on my PSP, it shows the following information :

Region : NTSC J
BIOS version : 4.5
CRC32 : 5660F34F
Date : 05/25/00 

I think the difference can come from the file size. Mine is 524288 byte. On the Internet, I see a reference of this BIOS and size seems to be 145 KB.

Have anyone else tried the same operation ? If so, what is the hash of the file you obtained ?

Also, I tried with Mednafen (from RetroArch/Ubuntu), I’ve renamed my file scph5502.bin but on game start I got a black screen.

I suspect Mednafen checks the CRC32 of the bios file and if it does not matches the expected one it’s giving a black screen. If it’s the case, it’s a pity because it prevents to play with your own dumped BIOS file. Maybe a warning would be better…


PSX BIOS from PSP 6.60 optimised to play games more smoothly: but how?
#2

The PSP BIOS from the internet has an MD5 sum of c53ca5908936d412331790f4426c6c33, while Mednafen expects a 5501 MD5 of 490f666e1afb15b7362b406ed1cea246. Mednafen should be able to load the PSP dump in place of the NTSC-U BIOS, at the very least (dunno about PAL). It shouldn’t refuse to load on a mismatching hash, but it will for a mismatching name.

5502 is the PAL BIOS. Did you try it with PAL games?


#3

Yes, I tried with a PAL game (Red Alert Retaliation French version).


#4

Issue solved ! I discovered that tool VMP2MCR (Windows) was the faulty part. Basically, if after converting the first part, you open the part 2 and click convert, the part2 input file was not loaded and part1 was still converted (into part 2). So the end-result was the 5 parts 1 were merged together. The solution was to close VMP2MCR after a part was converted and the reopen the application to convert the next part. Now I get the proper CRC32 !