Endless Loading issue in Resident Evil 2

Endless Loading issue in Resident Evil 2

So, i got a problem with the infinite loading when i tried to emulate RE2 using Duckstation core. This happens only with the doors connected to the Main Office. Here’s what I found out: that’s not a core problem, something is definitely wrong with Retroarch, because when i emulate this rom using Duckstation software with the same settings and the same save file, it works great without an issue.

So i wonder, what it can be ? Any idea ?

Video with this issue


That’s a strange one. Do you have all the necessary system files for the core? If you load a core, then go Information --> Core Info, it will let you know if you are missing any files.

If you are still having issues, you can also try the Beetle psx core, which does not have this issue (have completed RE2 multiple times on it).

It just says that i don’t have firmware files, but thats not true. If I didn’t have it, I wouldn’t be able to play.


As i said, i just download duckstation software from the github and say goodbye to retroarch, i have a lot of problems with this program in the past and now.

Have you tried the Swanstation core? It matches the latest stand-alone Duckstation version. The Duckstation core is based on an outdated version of Duckstation. Maybe it’s a bug that got fixed.


Yeah, that was helpd, thank you.

1 Like