Exact video settings for running on CRT TV


#1

Hi guys, I have a NTSC CRT TV, installed all native resolutions for the systems I intend to run via crtemudriver. All resolutions work, I have tested them with Calamity’s ArcadeOSD. I have enabled CRTSwitchres, 15khz & native in the options. But it doesn’t seem to be working right, and I am not sure what other video options need to be set:

What does aspect ratio get set to?

Integer Scaling?

Additionally I thought this feature is to have RA switch to the systems native resolutions correct? When I run for example a Sega Master System game, the resolution should switch to 256x192, instead when I go to video options it just shows 320x240. Shouldn’t it say 256x192?


#2

You need to make sure all the resolutions are installed in static mode. You need to install 200p 224p 240p 448i 480i. Tgere are others, check out the readme.md on the Retroarch Github.

Also yes it will switch to native resolutions for each core. However, windows can not do < 200p. This is a limitation within the windows drivers. So for these resolutions a close higher resolution is drawn. But the native image is used so there will be black boarder. Some of these boarders are hidden using offset porches.


#3

Hi Alphanu, ok so static mode is a must. A few more questions.

So when resolution switches, does it matter what aspect ratio it’s set to? I want it displayed as close to the original consoles as possible with no additional altering of aspect ratio.

Also, I was using super resolutions but decided to switch to using native resolutions instead for a more authentic experience. I installed all of them statically, but the interlaced resolution switching, it’s not working on correctly.

For example, the PSX bio screen is interlaced 640x480. It switches to interlaced, but when it displays the picture, I get a double vision picture. A black line is drawn down the middle of the screen and I see 2 Sony Diamonds, both on the left and right.

This does NOT happen when I use the super resolution method. Any idea what could be causing this? I can post pictures if needed.


#4

You can grab a cheap ATI for around £25 (HD5450) which native will work perfect with.

Windows does have an interlaced bug. Calamity has released a patch to fix this. It currently does not work with the later Windows 10 update.

The latest Nvidia cards may work better 10xx series. As Nvidia have removed the dot clock limitation.

For closest to original you will want core provided. However, currently super resolutions are a little stretched horizontally this is something I am working on.


#5

Ok, resolutions are switching correctly since installing in static mode, but serious bug happening. I have an ATI 6570 card that works great with crtemudriver. But when RetroArch tries to switch to an interlaced resolution (for example the PSX Bio screen), this is what it looks like. This is what I was trying to tell you about a double screen.

This only happens when you choose to install native resolutions in vmmaker…it doesn’t happen when using super resolutions but I stopped using that method because, like you said Retroarch displays the picture too wide. Indont know what’s causing RA to display it double.


#6

I am going to assume this is a 640x480@60 resolution.

Can you do a test for me?

when RetroArch is not running can you load ArcadeOSD, the application that comes with CRTEmuDriver. From the menu change to the installed resolution. Let me know if you get any of this double screen.

Another test to find out what resolution is causing this would be to put a shortcut to ArcadeOSD on your destop. Load a PSX game, press F1 to pause. Then press ALT TAB to go to your desktop and run ArcadeOSD this will show you the current resolution.

This information could help me narrow down your issue.


#7

Hey Alphanu, I found out what was causing this issue. I asked over at the BYOAC because I thought it may be an issue with CRTemudriver.

The double image was because 480p was being fed to my TV. The culprit was 2 things:

The service AMD External Events Utility needed to be disabled, also the option under advanced settings for “hide modes this monitor cannot display” was unchecked. Now it’s switching to regular 480i when the core calls for interlaced. They told me this is an issue with any other emu thats used on a CRT TV besides Groovymame.