Final Fantasy VIII memory card not detected

When I was running pangu jailbreak on ipad air 2 ios 8.1, I was not able to save in-game. Every time I exist the game all the data gets deleted. However there were time when I was able to save. I dont know why. That sometime when i am able to save in-game, a while later it will show up as corrupted data. Why does this happen anyway? I tried everything this forum said and nothing worked. I even used the “close content” Then I heard that taiG jailbreak fixes alot of problems. So I restored my ipad, updated to 8.1.1, then jailbroke with taiG. This time I got purchased flex 2 and retroarch to not work. I’m not sure if theyre related but i’ll just put flex 2 aside. Now, whenever I try to save in Final Fantasy VIII, it wont even detect the memory card. I thought retroarch didnt even support .mcr

What shoud I do now? by the way I did put .mcr files into .retroarch

Please Help

I’m having exactly the same problem with the same game. I’m using RA on iOS 8.1.2 TaiG jb. The savestates work fine, but saving in-game does not seem to work at all. When I save it apparently creates a save, but when I reset and try to load there is no save file. Also, I can’t find a save file anywhere on my device.

I haven’t tried with any other games yet.

Edit: I kept trying and now it seems to be working. It saves a .srm in the same folder as my rom.

У меня точно же такая проблема при переходе с диска на диск,есть ли решение?