FireTV official support?

Amazon sells a nice little set top box they call the FireTV. It runs android 4.2 with their own modifications. They also sell a game controller for it and they let you side load apps. I was able to install the current stable version of retroarch just fine using adb, but it would be awesome if you had it on the Amazon app store.

Here’s a link to the device page: … rds=firetv It’s stripped down brother called the FireTV Stick: … rds=firetv And the developer portal for the Amazon app store:

How was your experience running it on the FireTV?

There are a couple oddities.

I was using an xbox360 controller since the FireTV supports it out of the box (apparently I have to root it to use my PS3 controller which I vastly prefer).

The back, xbox, and start buttons default to back (like back on a phone), home, and menu. So you can’t map the back button in retroarch. This means getting creative for games that use select.

Performance wise, I was able to run everything up to PS1 games (with PCSX Rearmed). Medanfen PSX, Mupen64 and Desumune couldn’t run at full speed.

So other than the small problem with the controller, it worked great. The FireTV plus XBMC plus Retroarch makes it a really great livingroom device.

Edit: I forgot to mention two things. One Amazon makes it very annoying to access sideloaded apps. This can be worked around, but by default it’s through 3 submenus. Two retroarch totally fails to autodetect the controller, you have to manually assign buttons. Which is whatever.

My experience is, that it worked with RetroArch with the old menu. However with newer versions of RetroArch I find it impossible to configure controllers.

Dear Sirs, i am from Italy, I can’t install RetroArch on Fire TV Stick lite 2020 FireOS Please can you solve it? I try stable and also nightly, but nothing. Thank you in advance.

Hi everyone, i could install it in Fire TV (no stick) but in can´t download and install the cores, do you know how i can do it?

I have an Amazon Fire TV by Toshiba & have so far been unable to use RetroArch. I managed to install the application, and it seems to launch OK, but after that I have no control over the cursor - not with my PS4 dual-shock controller, nor my TV remote. My plan was to test it out here & eventually install it on a portable Amazon Fire Stick, but it’s the same OS, so I’m assuming if I can’t get it working on the TV, the same will happen when I try the Fire Stick. Any advice appreciated.

Can you use dolphin core on fire TV retroarch

AFAIK, dolphin-libretro has been broken on Android since the v9.0 update. We don’t know what broke it, exactly, but my Shield stopped running it as soon as I got the v9 update and hasn’t worked since. You might check out the standalone Dolphin apk.