Flickering Graphics in Games

guide
retroarch

#1

So in some 16-bit/32-bit games I’m getting flickering graphics. Examples include flickering drop shadows in Fire Emblem, the floating head in the intro of Shin Megami Tensei flickers, the map in F-Zero: Maximum Velocity flickers on and off, and they’re many more games that have this issue. From what I heard, flickering is caused by my refresh rate, which my monitor is running in 144hz, and that g-sync/freesync can fix this, but my monitor doesn’t have g-sync/freesync in. So I’m wondering if other people are having this issue and know any other solutions. Keep in mind that I already tried putting the refresh rate at 60hz and set the Retroarch refresh rate as default. None of these seem to work.

Video Example:


#2

You shouldn’t need adaptive refresh rates, but that would indeed correct it.

Since your monitor is 144 hz, I suspect it’s just syncing to audio and doing frame drops/dupes to maintain vsync, which is causing the stutters. I would recommend setting your monitor to 120 hz (at least temporarily; if this fixes your issue, you should be able to set the refresh in your retroarch.cfg and it will switch to it when you go into fullscreen), set the swap interval to 2 in settings > video, make sure vsync is on, and make sure you’re doing anything weird in your GPU control panel (e.g., forcing vsync through it; make sure it’s set to “let application decide” or whatever). If that doesn’t fix it, try disabling audio sync at the same time.


#3

Thanks I’m gonna try it later. I’ll let you know what the results were.


#4

Alright so I set the vsync swap interval to 2 and went into the retroarch.cfg to set the hz to the same as the default. I turned off audio sync and no more flickering! But then everything was running super fast at 144hz lol. So i’ll try either lowering it to 60hz or lock the framerate at 60 with Rivatuner.


#5

If you have swap interval at 2, you should set the refresh rate in your retroarch.cfg to 120.


#6

Hey I’m back. I stopped working on this issue a while back but now I’m trying this again. So whether I try running at 120hz with v-sync on with swap interval set to 2 or running at 144hz, turning off audio sync will make the game super fast. It may look like the graphics aren’t flickering, but I think it’s because it’s speeding alongside the rest of the game. Running at 60hz with audio sync off makes the game run normal, but the flickering is still there, even with v-sync on or off, so this is where I’m stuck right now.


#7

Can you try the drop-shadow test on the 240p test suite? That’s designed to catch exactly what you’re mentioning and it will rule out any game-specific flickering issues (that is, sometimes the flickering happens on real hardware, too).


#8

Can the 240p test suite be used on PC since I’m running the PC version of Retroarch?