Flycast Core for atomiswave on Xbox Series X

Trying to get Metal Slug 6 to run through Retroarch, and man, atomiswave emulation is eluding me with this frontend. I’ve checked the info for the flycast core, and it says all the required BIOS files are present. Have them in the dc folder in system. If I move the bios files anywhere else, it’ll tell me the BIOS is missing when I attempt to load the game. Got the rom & bios from the most recent MAME set. Contents of is bios0.ic23 and bios1.ic23. I have tried Metal Slug in both 7z and zip format, along with trying different video renderers. My emulator immediately crashes and sends me to the dev mode menu with DX12 & the opegl wrapper, while DX11 stutters. I get a black screen for a bit, like it’s trying to load something, then the emulator crashes.

I got the game working flawlessly first try with the same files in the standalone Flycast emulator in my Series X’s dev mode. Works with both 7z and zip. So I don’t think it’s the files

1 Like

yeah, sounds like the files are probably fine. Have you tried generating a verbose log to see if it has any clues?

1 Like

The bios is incomplete or is an old version. This is the one for the current set 0.254.

Thanks, looks like my rom was outdated after all :sweat_smile: I have the current one, my game file is also exactly as yours is. Still not working unfortunately

Looks like this is your issue:

[libretro ERROR] core/rend/dx11/dx11_texture.cpp:99 E[RENDERER]: Texture creation failed type 1 dim 128x128 mipmap 0 (included 0)
[libretro ERROR] Verify Failed  : texture != nullptr
 in UploadToGPU -> /builds/libretro/flycast-upstream/core/rend/dx11/dx11_texture.cpp : 101
[libretro ERROR] shell/libretro/libretro.cpp:3147 E[COMMON]: DEBUGBREAK!

You said it craps out with the other video drivers, as well, though?

The two-file bios is a bit old, about a year and a half ago. If you updated the bios, the game romset has to be exactly the same version, or you will get an error.

Yeah, I’ve tried turning off automatic driver swapping and the other drivers didn’t work. When I allow the core to swap drivers it swaps to DX11

Thanks for the help, to both you and hunterk! I’ve updated my, and mslug6 all to mame romset .254, and tried the game as both and mslug6.7z, still no dice. After updating, both compressed files still run in the standalone flycast without any issue. It’s also running on Retroarch on my laptop, so I tried porting over those config settings over to my Xbox, & make the setup the same. That didn’t work either

For Atomiswave you don’t need the Naomi bios, neither is it necessary to have the game in two formats, one is enough. Have you tried deleting the config file? maybe it’s a better option than porting the configuration.

I’ve tried a fresh, from scratch install to no avail

I’ve read that DX11 support is relatively new, and I’ve seen some videos of it working, although only OpenGL used to work. But I can’t go any further than recommending the correct sets. :no_mouth:

My advice, if you want to successfully complete this mission, is to follow the steps given by hunterk, to the letter. :grimacing:

MAME .254 is the correct set, yeah? I have the 3 file He told me to make a log, which pointed out the video driver, but none of the other drivers work. I spent a few hours messing around with combinations of settings relevant to the driver but it seems I’m out of options for now

At least it functions on the standalone Flycast core on Xbox, so I can still play on Xbox, and it functions of my laptop in Retroarch with the Flycast core, so I use that when I wanna go for achievements. Other people have Flycast running atomiswave just fine on the UWP Retroarch on the Series X, so I’m sure there’s something silly I’m missing, just can’t figure out what that is, the log at least let’s us know it’s the driver. But why?

If they implement DX12 support one day I’ll be golden

Ah, seems to be a known issue. Here’s the github ticket for tracking purposes:

1 Like