Flycast crashes to desktop after bios with Radeon cards

I recently bought a 6800 XT and everything runs flawlessly except for Flycast, which crashes when the boot sequence is started. This seems to be the issue: https://www.reddit.com/r/RetroArch/comments/l04f0p/can_anyone_with_a_amd_radeon_card_please_see_if/

It seems some AMD cards cannot use this core at all. Is there any fix for this?

Thank you!

I have an AMD, though it’s an RX 590. Though I have no idea if that’s “Radeon” or not. What I do know is Flycast is, let’s say quirky, with the video drivers sometimes.

  • What video driver are you running RA in?
  • Are you using DC BIOS or the HLE BIOS?
  • Have you tried the other BIOS that you are ‘not’ using yet?
  • Also, are you on the latest stable RA? 1.9.1, I believe.

I know when I use Vulkan, I can’t get the Sonic Team video on Dreamcast to display. When I used the old OpenGL I had to set a hardware context setting to get any video. I feel like I also had crashing issues at some point, but I’ve re-setup RA so many times over the last several years who can remember what caused what.

For what’s it’s worth, currently I run GLCore and I think that takes care of the hardware context setting on it’s own now. I’d have to double check that, that’s pretty recent.

1 Like

Hey, I 'm using the latest video drivers but it happened will all driver releases since I got this card. The latest version is Adrenaline 21.3.2. I’m also using the DC Bios, HLE seems to be ok but of course I get glitches in-game without the actual bios. Latest RA is 1.9.1 here too.

This was all working fine with my old Nvidia 1060 in my laptop, so something is weird with Flycast.

Sorry I wasn’t more specific, what I meant was, what video driver do you have RetroArch set to use in Settings>Drivers? I’d encourage you to try glcore, d3d11, and vulkan, and see what results you get.

It might also help to check the log, if you run this command you can generate a log.txt that might tell us more. Obviously you’ll want to change the path here from the X:\ drive to however your own directories are setup.

"X:\Emulators\RetroArch\retroarch_debug.exe" --verbose --log-file log.txt

Hello!

I use vulkan due to faster and more stable performance with shaders since I played in my old PC.

  1. glcore does not even load the bios screen, I get a crash to desktop
  2. directx11 loads the bios animation and then crashed to desktop once you press start or let ir run
  3. vulkan shows the same behavior as directx11

I can play any other core just fine, I have this issue only with Flycast.

This would be my log.txt:

https://drive.google.com/file/d/1ieH3WZv_kVXtM7JnSjf6S2PBwozursO5/view?usp=sharing