Flycast lightgun games

How are you guys playing the lightgun games in flycast core for Android? Normally there is a crosshair that I can use the d pad to control. Not seeing that as on option for games like ranger mission. I went into the options menu in retroarch quick menu and enabled lightgun settings and made player one red. Still didn’t show up. Says I have to toggle off quick menu for it to show. Not sure what that means. Do I need a mouse or actual light gun to play flycast light gun games?

Yes, you need a pointer device to play lightgun games, either a mouse or an actual lightgun.

1 Like

Thanks flying head. Trying to get lupin shooting to work. It says error 1 game is not acceptable by main board. Do you know of a fix? I tried entering device mode with no luck messing around with the settings there. Both zip and chd are mame0.184.

There’s been an incompatible change on this rom in mame 0.201. Try renaming your chd to gds-0018a.chd, or get a more recent mame romset.

1 Like

The name change worked liked a charm. I didn’t even think about going over the Mame version change logs for the answer. Retroarch is really pretty amazing Thank you so much.

Got myself a Bluetooth mouse. It works fine in menu. Was able to bind the left to fire and right to reload. Crosshairs are still not showing up. Just the mouse arrow pointer shows up in the game but does nothing. Tried to switch input player one to binding from controller or retropad to mouse but that’s not an option. Any guidance guys?

On desktop you should bind player one to “Lightgun”. However I’m not sure how this works on Android. I just plugged in a mouse and I can’t change the controller type at all.

I don’t think retroarch Android is recognizing the mouse. When I turn on the Xbox controller it prompts a message at the bottom saying Xbox controller set and shows up in the user controller binds. Doesn’t do that for the mouse. Also mouse index is locked at zero. I read that desktop has multiple numbers to test which one works for your mouse. Guess no lightgun games on the go yet.

Anyone gotten a light gun game to be playable with mouse or controller using the flycast core?

Mouse works for me, at least in Lupin The Third - The Shooting, my only issue with it is the lack of a crosshair*. While the game did not have crossairs built into it, the lack of an overlay crossair from the core itself for the mouse is a big setback. @flyinghead have you considered adding this feature? Maybe this should be up to RetroArch itself to allow such an option without the core involvement (if possible)? [Yes, his reply on post below]

It took me a few tries but the way I got the mouse working was as such:

  1. In RetroArch input settings, Port 1 Binds, bind mouse buttons to the lightgun actions (Gun Trigger, Gun Reload, Gun Start, Gun Select), I went with left-click for trigger, right-click for reload and wheel-button for start, Gun Select in this case is for credits and I assigned it to a 4th button on my mouse, you can assign it to a controller or keyboard if you want;
  2. Start the game and then go into the quick menu, Port 1 Controls, switch Port 1 device type to Light Gun;
  3. Save Game Remap File to keep these settings on next run;
  4. Enable Show Light Gun Settings in core options (quick menu), may have to exit menu or restart game/core for it to show the crosshair color options;
  5. Quick Menu > Overrides > Save Game Overrides;
  6. Now, this may be overkill, but I’m not sure of a proper way to do this so… if you notice now the crosshair will appear in every Flycast game (and the reason for step 5); quit the game and load any other game with Flycast, go into the quick menu options and change the port 1 to lightgun so that the settings will appear in options again, disable Show Light Gun Settings, go back to the port 1 control and set the device type back to what it was (controller possibly), close game, quit retroarch, load any game again, it whouls no longer show the crosshair;
  7. Load your Lightgun game again and it should show crossair and everything should work from the as you saved the settings.

This should be enough, if not , without quitting the game go back to the main RetroArch input settings, Port 1 Binds, switch the Mouse Index to 1 and try again, then try to switch it back to 0 to have it work in game and RA interface.

There’s a builtin crosshair that just needs to be enabled in the core options > Show Lightgun Settings then choose the crosshair color.


Ugh, I feel dumb… so obvious… thanks for the quick reply!

The process is a bit convoluted though. The option appears only after setting port device type to lightgun, which is well thought, but makes it look as if the option does not exist at first glance. Then, when enabled, the crosshair color options didn’t show, I think I had to quit the game and back for it to show. Then, you have to create control remaps and overrides for specific games, start another game, disable the lightgun, restore the device type… and yeah, now it’s okay.

There may be some shortcuts there, but for the most part these extra steps are required to enable the controls and options for only one game and not the others. Anyway, maybe it’s because I’m not used to the setting, but next time I think I’ll edit a game cfg by hand instead, should shave some time off I think.

Thanks for the advice guys. Hope the process works for my phone.

Sadly I can’t get it to work on my Rog phone 2 with a corded mouse. The pointer shows up. I got to step 2 and port 1 device is stuck on controller. Device index is disabled and mouse index is stuck at 0.

Is there a way to play the Naomi gun games with the crosshairs and a controller like Terminator Arcade on MAME?

Wanted to start a topic, but there was no option.


Having an issue with Flycast and Ultimarc Lightgun.

I have it setup apart from one issue, and i;m not sure if it’s a flycast or retroarch issue.

The issue is that in retroarch menu in HOTD2 I am unable to assign the trigger to any input! Oddly, i;m abe to navigate within retroarch using the lightgun and the trigger highlights and selects menu options, but refuses to bind to anything (ie Gun Trigger input)

I have spent most of today trying to sort this out, and have added this to udev/rules.d which was suggested in several places?

Set mode (0666) & disable libinput handling to avoid X11 picking up the wrong


SUBSYSTEMS==“usb”, ATTRS{idVendor}==“d209”, ATTRS{idProduct}==“160*”, MODE=“0666”, ENV{ID_INPUT}="", ENV{LIBINPUT_IGNORE_DEVICE}=“1”

For ID_USB_INTERFACE_NUM==2, re-enable libinput handling.

SUBSYSTEMS==“usb”, ATTRS{idVendor}==“d209”, ATTRS{idProduct}==“160*”, ENV{ID_USB_INTERFACE_NUM}==“02”, ENV{ID_INPUT}=“1”, ENV{LIBINPUT_IGNORE_DEVICE}=“0”

And i also have disabled the mouse in the retroarch menu, but nothing seems to work

I can assign the trigger within retroarch for mame ok, but not flycast?

Any suggestions welcome.