Flycast running at 55fps

Is there any setting that would keep Flycast running at 55fps? I was convinced it was some PAL setting, but I have everything set to NTSC so I’m not sure why it won’t go to 60fps. I know I’m for sure using NTSC copies of games as well, so it’s not that. Plus I’m using the normal Flycast core, not the WinCE one, so no performance hit from that either…

Running at native resolution, and outputting 1920x480, so nothing crazy. Happens if I go to the LCD and use 640x480 as well.

I can fast forward too, so I don’t imagine that my system is underpowered. For reference:

  • AMD R9 390X 8GB
  • Intel i7-4790k 4.0Ghz
  • 16GB RAM

Any thoughts?

Does it happen for all games or for a specific game (and which one(s)?

In core options, enable Threaded Rendering and Synchronous Rendering.

Also you might want to try the wince core as performance should now be the same or better than the regular one.

1 Like

Ok, so I ran a whole bunch of tests. Switching to WinCE totally worked… well kinda. (should mention I was using the latest as of last night for both core versions.) The games are now running at 70-80 fps. This is great in that it’s not slow anymore, but it’s strange. All the other cores run at 60fps, because my system is locked to that; unless I hold fast forward.

When I fast forward on these other cores, the fps counter ramps up accordingly. On this core though, I don’t see the fps shoot up in-step with the core speed. It’s very odd. Still it’s no longer slow and I love it. I’ve got nothing to complain about there, it’s just very very odd so I figured it was worth noting.

There’s one last thing though, which is a larger issue. Whenever I test Dreamcast I use Sonic Adventure, just a habit I guess, anyway upon switching to WinCE I noticed some terrible audio distortion going on. Just really scratchy awful sounds in the middle of speech and some of the music. I decided to run a couple more games for good measure so I tried out Crazy Taxi and Sonic Adventure 2 as well, and no distortion occurred.

I switched back to regular Flycast and the distortion is not present in Sonic Adventure. Then switched back again to WinCE, and it returned. I played with the DSP setting, synchronous rendering, and threaded rendering, but I couldn’t get the distortion in Sonic Adventure to go away.

Possible bug of some sort? Def felt I should mention that one. Still the speed is greatly improved on my system so that’s a major plus. I highly doubt you get thanked enough for all your hard work with this core, so seriously I just want to say Thank You. Honestly and truly. My work would be utterly incomplete without Dreamcast, and the work you do allows me to have it running as well as it does.

Seriously, thank you <3

I’ve had a similar issue for low framerates with latest nightly builds as of 8/20/2019. When ever i upscale games from default 640 x 480 to 1920 x 1080 it slows down. Soul Calibur runs 60fps at 640 x 480 but at 1080p it drops down to 13 fps? When the core was named Reicast i was able to upscale to 4k but now it runs super sluggish. I’ve tried both cores the Flycast & Flycast WinCE with core options, enable Threaded Rendering and Synchronous Rendering. No luck, any suggestions?

Windows 10 x64 i7 7700k @ 4.50 GHz 16 GB RAM Nvidia GTX 980ti