Force slow motion ton function as a second level of fast forward?


#1

Or alternatively, speed up the default speed?

Here’s what I mean. I’m playing an RPG that is rather slow paced. I’d like to play at 1.5x speed normally, but then have a 5x speed when I need to grind.

I’ve gone into the config file to change fast forward speed to 1.5x, and tried to set slow motion at a negative value hoping that would result in it speeding the game up, but no such luck.

Is there anyway to trick RetroArch into what I want to accomplish, or is there some other value I can edit to get this effect?


#2

No way to do it, AFAIK.


#3

This actually sounds kind of interesting to me as well, 'cause sometimes my default FF just isn’t fast enough; albeit rarely.

In theory, would there be a way to make it possible to have hold FF do one speed setting, and then toggle FF do another?


#4

Try to run the game unsync’d and frame-limit it with riva tuner. So in RTSS, set the framerate to 300fps (x5 speed) and then in RA, 1.5x fast forward toggle. If that works, you can switch between speeds with just one button press.


#5

That sounds like a plan, but could you give me a little more info on how to run unsynced? I’ve turned off vsync and gpu sync, but there has been no change to FPS.


#6

Apologies for the double post; I’m still in the new user phase and my posts are being reviewed, so I can’t edit.

I was forgetting to desync the audio. Once I did that, I started running at 300fps.

It doesn’t work though. The frame throttle in RA effectively does the same thing as RTSS; it acts as a cap. So while RTSS is set at 300fps, if I set my frame throttle in RA to 1.5x, I can’t get any faster than 90fps.

I thought about using Slow Motion at 1.0x and use that as my toggle, but no dice. With everything desynced, Slow Motion does nothing at all.

Seems like this is impossible unless there are any other ideas out there!


#7

But have you tried to set a key to enable/disable RA’s throttle? My idea is that RA would be running at 300fps by default via RTSS and once said key is pressed it limits itself to 90. It should work unless unsyncing disables RA’s frame limiting capabilities.


#8

I did; unless I am conflating “toggle fast forward” with “enable/disable throttle” Let me explain step-by-step and maybe you could let me know if I did something wrong?

I disabled Vsync and Audio sync. Just in doing this, I get a super fast frame rate.

I set RTSS to limit RA to 300 FPS. This works.

I set L1 to FF and R1 to Slowmo. My FF limit is set to 1.5x and Slowmo is set to 1.0x (normal speed).

RA is now capped at 1.5x without toggling FF. The FF speed acts as a cap; when it is set and not toggled on, the frame rate will not exceed your FF rate.

I set FF back to 0.0x (uncapped). Back to super speed. I toggled Slowmo, but there is no effect.