Full screen not working


#1

I’m running retroarch 1.7.5 on a Dell laptop with high resolution (3200x1800) and I can’t seem to get if to switch to full screen. It has worked sometimes, but then next time I start the computer the retroarch menu just covers a quarter of the screen. If I toggle between full screen and not full screen, the size remains the same. Same result starting with -f.

Switching to full screen gives me the following log:

[INFO] [Video]: Does not have enough samples for monitor refresh rate estimation. Requires to run for at least 4096 frames.
[INFO] [Audio]: Set audio input rate to: 29970.03 Hz.
[INFO] [Video]: Video @ fullscreen
[INFO] [Wayland]: Physical width: 290 mm x 170 mm.
[INFO] [Wayland]: Video mode: 3200 x 1800 @ 59.9820 Hz.
[INFO] [Wayland]: Setting buffer scale factor to 2.
[INFO] [Wayland]: Seat name: seat0.
[WARN] [Wayland]: Compositor doesn't support zwp_idle_inhibit_manager_v1 protocol!
[WARN] [Wayland]: Compositor doesn't support zxdg_decoration_manager_v1 protocol!
[INFO] [EGL] Found EGL client version >= 1.5, trying eglGetPlatformDisplay
[INFO] [EGL]: EGL version: 1.4
[INFO] [Wayland]: Loaded keymap.
[INFO] [GL]: Found GL context: wayland
[INFO] [GL]: Detecting screen resolution 3200x1800.
[INFO] [EGL]: Current context: 0x564464d89270.
[INFO] [EGL]: eglSwapInterval(1)
[INFO] [GL]: Vendor: Intel Open Source Technology Center, Renderer: Mesa DRI Intel(R) HD Graphics 615 (Kaby Lake GT2) .
[INFO] [GL]: Version: 3.0 Mesa 18.3.1.
[INFO] [GL]: Using resolution 3200x1800
[INFO] [GL]: Default shader backend found: glsl.
[INFO] [Shader driver]: Using GLSL shader backend.
[INFO] [GLSL]: Checking GLSL shader support ...
[WARN] [GL]: Stock GLSL shaders will be used.
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] [GLSL]: Linking GLSL program.
[INFO] Setting up menu pipeline shaders for XMB ... 
[INFO] [GLSL]: Compiling ribbon shader..
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Compiling simple ribbon shader..
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Compiling snow shader..
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Compiling modern snow shader..
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Compiling bokeh shader..
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Compiling snowflake shader..
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] [GLSL]: Linking GLSL program.
[INFO] Resetting shader to defaults ... 
[INFO] [GL]: Using 4 textures.
[INFO] [GL]: Loaded 1 program(s).
[INFO] [GL]: Using GL_RGB565 for texture uploads.
[INFO] [udev]: Plugged pad: Xbox 360 Wireless Receiver (XBOX) (1118:673) on port #0.
[INFO] [udev]: Pad #0 (/dev/input/event21) supports force feedback.
[INFO] [udev]: Pad #0 (/dev/input/event21) supports 16 force feedback effects.
[INFO] [Autoconf]: 261 profiles found.
[INFO] [autoconf]: selected configuration: /home/mattias/.config/retroarch/autoconfig/udev/Xbox 360 Wireless Receiver (XBOX).cfg
[INFO] [Joypad]: Found joypad driver: "udev".
[INFO] [Font]: Using font rendering backend: freetype.
[INFO] [Video]: Found display server: null
[INFO] [PulseAudio]: Requested 24576 bytes buffer, got 18432.
[INFO] [Font]: Using font rendering backend: freetype.
[INFO] [Font]: Using font rendering backend: freetype.
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/menu_room.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/menu_room_lan.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/menu_room_relay.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/menu_shutdown.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_DPAD-U.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_DPAD-D.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_DPAD-L.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_DPAD-R.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_STCK-U.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_STCK-D.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_STCK-L.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_STCK-R.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_STCK-P.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_SELECT.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_START.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_BTN-U.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_BTN-D.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_BTN-L.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_BTN-R.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_LB.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_RB.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_LT.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/input_RT.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/menu_check.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/menu_add.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/menu_brightness.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/menu_pause.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/menu_apply_toggle.png
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/monochrome/png/menu_apply_cog.png
[INFO] [LED]: LED driver = 'null' 0x5644618d6540
[INFO] [MIDI]: Initializing ...
[INFO] [MIDI]: Input disabled.
[INFO] [MIDI]: Output disabled.
[INFO] [MIDI]: Initialized "null" driver.
[INFO] Game focus is: : off.
[INFO] [GL]: VSync => on
[INFO] [EGL]: eglSwapInterval(1)
[INFO] [Font]: Using font rendering backend: freetype.
[INFO] [Font]: Using font rendering backend: freetype.
[INFO] [Font]: Using font rendering backend: freetype.
[INFO] [Font]: Using font rendering backend: freetype.

#2

Can you please provide WAYLAND_DEBUG output (run with WAYLAND_DEBUG=1 retroarch)?


#3

And please send your environment specs (GPU, distro, DE, kernel)


#4

Also try fresh RetroArch 1.7.6