Game.Com in Retroarch


#1

Don’t ask, it simply happened and why shouldn’t it, every game should be preserved for future generations to…enjoy.

Anyway, via the MAME core, Tiger Game.Com works. There are some graphical glitches and sound is not perfect, but having played one of these when they came out due to an unfortunate friend of mine who today probably hates his parents, the experience is pretty close to how I remember it. Sluggish, slow, and clunky.

First up, set up your roms like this, with bios zipped up in the parent folder

Then, make sure you got these bios in the system/mame folder as well.

Now, you’ll be ready to run Game.Com games like a true champion. Just load your mame core and have at it.


#2

Nice guide! Is that border and the LCD effect built in?

also, Noo Saibot??


#3

[QUOTE=hunterk;45712]Nice guide! Is that border and the LCD effect built in?

also, Noo Saibot??[/QUOTE]

No I made that one myself quick for showcase. But I zipped it up and attached it here. Just unzip straight into your retroarch folder.

https://mega.nz/#!55MxVZBD!HWIzYNLOvA5QsvuQT1s5oFu2dTDk9-PDgWbH1KOFNEY

Some more shots


#4

Well it looks great :slight_smile:

We can see about adding it to the console-borders shaders, if you like.


#5

[QUOTE=hunterk;45737]Well it looks great :slight_smile:

We can see about adding it to the console-borders shaders, if you like.[/QUOTE]

I’ll improve it a bit then submit it :slight_smile:


#6

I heard Castlevania - Symphony of the Night was being developed for this. It’d be interesting if there was a prototype out in the wild somewhere.

Then again there’s still no Castlevania - Resurrection prototype floating around… and the Game.com isn’t even remotely as popular haha.


#7

I know this is an old topic but I’m having trouble getting Game.com to work.

  • I’m using the MAME (0.193) core

  • I used clrmamepro to rename all my roms using the No-Intro dat file e.g. Sonic Jam (USA) .tgc is compressed inside Sonic Jam (USA).7z

  • I placed the bios “gamecom.zip” in the root of the “RetroArch/System” folder

Does anyone know what I’m doing wrong?


#8

MAME cores don’t use BIOS the same way as most cores (that is, put it in ‘system’). They typically treat them like parent ROMs, so they need to be in the same directory as the content that requires them.


#9

Think the easiest way to use mame’s console side is via the software list. I did a short guide about it here, for it to work, you need to build the software list using clrmamepro and the mame hash file.

You then need to create a mame folder in the root of the “RetroArch/System” folder, thjen in the mame folder create a hash dir and a roms dir, put the gamecom.xml in the hash dir and gamecom.zip in the roms dir, also create a gamecom dir in the rom dir with all the game.com games in it.

Then create a file sonicjam.cmd and put this in it:

gamecom -cart1 sonicjam -rp /Games/retroarch/mame/roms/

just point to where your “RetroArch/System” folder is!


#10

Thanks for the responses.

  1. Where would I put the sonicjam.cmd file? Would it go in the “RetroArch\system\mame\roms\gamecom” folder?

  2. I’ve never built a software list in clrmampro before, do you know of any good tutorials I could follow to help me build a software list?


#11

You can put it there, I keep mine with my roms, but you can put it anywhere you want, I tried putting it in ~/home/launchers/mame/gamecom and it still worked.

It shouldn’t be any different than using a no-intro dat file. Open clrmamepro drag and drop the gamecom.xml file on to the window, press ok, go to new datfiles Screenshot at 2018-01-11 08-20-57

open the tiger game.com one, press default, choose your path IE “RetroArch/System/mame/roms.gamecom” press the rebuild and point the source to where your no-intro roms are, and rebuild.


#12

Thanks again for your help te_lanus I used clrmamepro to rebuild my set and they are all named correctly now, however the cmd file isn’t working properly, which I assume I would use to launch sonic jam.

I tried editing the path you mentioned in your cmd file “/Games/retroarch/mame/roms/” to point to my retroarch/system folder like you mentioned but it isn’t working

gamecom -cart1 sonicjam -rp H:\LaunchBox\Emulators\RetroArch\system\


#13

I’ve followed these steps and get it to load to the start screen where it says cartridge, phone book, etc, but I can’t get the actual game to start. What am I doing wrong?

Thanks,

–Jason


#14

Need some help to get this to work as well

I followed the steps to run it via MAME. Placed the bios in the system folder. I also placed a copy of it in the roms directory. But when i try to run a game everything just closes.


#15

You have created a cmd file, as I stated here? I tried it and it still work,

My rom dir:


#16

No, i’m trying to make it work with the traditional way. I have a mess core from 2015 and it works but it’s outdated and the games are not very well emulated. That’s why i need MAME. But the whole thing with the software lists and the cmd files… I am using Hyperspin, will this method work with it?

Regular MAME also works without software lists. But i need the RetroArch version for the shaders.


#17

should, if you tell hyperspin that cmd files are roms. cmd files is just an easy way to get command-line arguments to mame, thus you could point to any rom to get it to work.

This is one I have to play Donkey Kong 3 on the Sharp X1:

x1 -flop1 "/Games/Romz/MESS/Software/x1/Donkey Kong 3 Dai Gyakushuu.zip" -rp /Games/Romz/MESS/Bios

I use it with Lutris on Linux


#18

Thanks… i will try this if nothing else works as it’s a bit above my head. Just one question though.

MESS standalone works.

MESS RetroArch works.

MAME standalone Works.

MAME RetroArch doesn’t work.

Why would all the others work but MAME RetroArch needs cmd files and the like? Is there something wrong with the core itself?


#19

Lol, i figured it out.

In the “retroarch-core-options.cfg” there is this line:

mame_boot_from_cli = “disabled”

I changed it to “enabled” and now it works. All you need is the bios in the same folder as the roms. :slight_smile:


#20

Is there any current means of getting the Gamecom Games running? Android method???