Gamefixes pcsx2

A lot of games require game-specific hacks that are in pcsx2. Can we use gamefixes with the pcsx2 core?

I think so, yeah. Are they not included in the setup assets?

I just don’t see any way to enable them in the core options. In standalone pcsx2 gamefixes are enabled via a menu option under config -> emulation settings.

I was under the impression the ‘automatic gamefixes’ option was in effect. I can’t say I’ve used the pcsx2 core even once, though, since I don’t have Windows.

1 Like

The “auto” option doesn’t always do what it’s supposed to do, sometimes you have to manually set a gamefix in pcsx2. Silent Hill 2 for example, you have to enable manual gamefixes and then select “Switch to GDsx software rendering when an FMV plays” otherwise you get horrible stuttering during FMV.

1 Like

@hunterk

Sorry to bug ya again about this, do you think I should just open an issue on GitHub for this? Really need manual gamefixes added to the core options if you want all games to run properly, I think

Sure, you can open an issue. I don’t think you’re going to get them in the core options any time soon, as that would be a lot of work, but maybe support for an ini file or something. Dunno.

1 Like

Hello, gamefixes for the game : Shinobido way of the ninja. Access to the garden . Pcsx2 -> Clamping option not again in the retroarch.

without this option, the game is blocked.

I play to the xbox series X. Retroarch is the best for gaming old shcool game

Sorry i’m french and lost :rofl:

1 Like

I would recommend using standalone PCSX2 until support for manual game fixes is added to the Retroarch core. Might take a while.

1 Like

thanks, my ninja will wait for a fix to get back to his garden :sweat_smile:

( i have not pc for play at the moment)

I have resolved my bug. In the folder ‘‘inis’’ to pcsx2 (in the xbox series x)

Pcsx2_vm.ini

Change the ‘‘FPUFullMode=disabled’’ to enabled

2 Likes