Games work in dolphin but no retroarch dolphin core

Just want to make sure I’m not missing something obvious here. I’ve tried loading wario world and wave race but both freeze when using retroarch with the dolphin core.

They both work fine when I load them with the normal dolphin emulator.

I have messed with the core options - is something in there to blame? Or is just related to the current state of the retroarch dolphin core? I’ve also placed the Sys folder in the system/dolphin-emu folder.

For context, a lot of gamecube games work fine for me with the dolphin core.

1 Like

Haven’t tested Wario World recently, but Wave Race also freezed in most tests I did some weeks ago on the dolphin core. These are my conclusions:

-It’s some strange bug whinch is triggered when shaders are active (yes, RA shaders), don’t ask me why, but ehen I completely disable RA shaders Wave Race doesn’t freeze anymore.

-I think the bug itself is on dolphin, as I remember lot of time ago having similar freezes with the same game on standalone dolphin, but very occasionally (maybe 1 of every 5 runs, while on RA its almost 100%).

-I solved it modifying a bunch of core options, but I cannot remember exactly which parameters changed, here’s my core options file (the one that avoids the freeze):

dolphin_bt_continuous_scan = “Off” dolphin_cpu_clock_rate = “100%” dolphin_cpu_core = “JIT64” dolphin_dsp_hle = “enabled” dolphin_dsp_jit = “enabled” dolphin_efb_scale = “x1 (640 x 528)” dolphin_efb_scaled_copy = “disabled” dolphin_efb_to_texture = “disabled” dolphin_efb_to_vram = “disabled” dolphin_fastmem = “disabled” dolphin_force_texture_filtering = “disabled” dolphin_gpu_texture_decoding = “disabled” dolphin_ir_center = “50” dolphin_ir_height = “50” dolphin_ir_mode = “Mouse controls pointer” dolphin_ir_width = “50” dolphin_language = “English” dolphin_load_custom_textures = “disabled” dolphin_log_level = “Error” dolphin_max_anisotropy = “1” dolphin_mixer_rate = “32000” dolphin_pal60 = “enabled” dolphin_progressive_scan = “enabled” dolphin_renderer = “Hardware” dolphin_sensor_bar_position = “Bottom” dolphin_shader_compilation_mode = “a-sync UberShaders” dolphin_wait_for_shaders = “disabled” dolphin_widescreen = “disabled” dolphin_widescreen_hack = “disabled”

Greetings.

1 Like

I appreciate the reply! I’ll mess with the core options to see I’d that fixes it.

Ok, waverace works now. If any of those settings helped, they did NOT need to stay on those settings to successfully start the game a second time. So that leads me to believe it was a shader compilation issue, because the shaders were compiled and saved to disk if I understand how shaders work.

However, wario world still does not work after flipping every core option possible. I confirmed the gcz file works in regular dolphin again without issue.

Also confirming that f zero does not work with the above settings flipped or not.

Curious, I don’t have any problems with Fzerogx (pal) and I’m not using have specific options

Mine are US. Not sure what the discrepancy could be besides hardware, OS or retroarch and core version. Normal dolphin still runs everything fine.

I’d be willing to run tests if it helps the devs.

Hi, downloaded a fresh copy of Retroarch 1.8 and Dolphin core make crash retroarch. It only happens with this core, all other cores work fine.

I was using this core since months, but now it’s impossible to play with it.

Any suggestions?

Update the dolphin core, don’t use “gl” as a video driver as there’s an issue with it right now, prefer “glcore”.

Alternatively, if you still want to use “gl”, then disable settings>core>“allow cores to switch the video driver”.

Hope this can be fixed soon.

1 Like

Hi Tatsuya79, and thanks for your answer.

Please, where can I disable de “gl” video driver inside Retroarch?

Thanks in advance.

Edit: I found the option and now with GLcore driver emulator Dolphin works like a charm!!! Thank you so much Tatsuya!!! Thanks a lot!!!

Thank you! This solved the issue for me!

Hi! I also have problem with dolphin. It was working just fine, but suddenly I can’t lunch any game, that were working fine previously. Any ideas for fix? I’ve tried changing drivers or “allow cores to switch the video driver”, but it didn’t help. Thanks in advance for help :slight_smile:

edit: I’m usuing Pop_OS! (ubuntu)