Garbled text in games running PPSSPP core

I tried both Metal Gear games, and Mega Man X Maverick Hunter, and all 3 of those games require you to read/make choices/ input a name right at the beginning of the games. I took a screenshot of Metal Gear Portable Ops. Any ideas on how to fix this would be appreciated. Also, these games all run fine in the standalone PPSSPP.


I think this has to do with the PPSSPP assets. I think it needs an updated atlas.zim or something like that.

Thanks for the reply, and forgive my ignorance, but is this something I can fix by downloading a file, or is it something that a developer needs to do before it can be fixed?

You need to put the content of stand-alone PPSSPP\assets into RetroArch\system\PPSSPP (without the “assets” folder, just the content).

And the flash0 folder (with the folder this time).

Thanks for the tips. Unfortunately it’s still not working. I actually copied the ‘atlas’ file earlier because I was getting errors on a few ROMs to where they wouldn’t even load, but I went ahead and copied everything this time.

Try copying everything here into your ppsspp folder in \system\ppsspp

This worked for me

[QUOTE=Rick74;47592]https://github.com/lakkatv/libretro-ppsspp/tree/master/assets

Try copying everything here into your ppsspp folder in \system\ppsspp

This worked for me[/QUOTE]

This worked. Thank you so much!

Guys this issue is back for me.

I’ve repeated all of the above steps and it’s still garbled. :frowning:

Edit: Copying assets from the latest standalone version of PPSSPP fixed the problem.

Thank you guys for posting this. I just found this topic and I had the same problem. The solution definitely worked.

Here’s a link to the latest update ( as of 3-14-18) for assets if anyone else needs it: https://github.com/hrydgard/ppsspp

2 years later… but I was getting very similar garbled characters to the image above in retroarch with ppsspp on osx. I downloaded the ppsspp standalone app from here:

https://build.ppsspp.org/?page/downloads#osx

When you unzip this, you can just play the ppsspp app standalone. But if you want to fix retroarch, you can right click on PPSSPPSDL.app and pick Show Package Contents. Find Contents->MacOS->assets and copy the assets folder to your RetroArch/system folder. Then rename assets to PPSSPP (make sure you don’t already have a PPSSPP folder). Now you should have the folder RetroArch/system/PPSSPP with this inside:

7z.png Roboto-Condensed.ttf compat.ini flash0 gamecontrollerdb.txt lang langregion.ini ppge_atlas.zim rargray.png shaders ui_atlas.zim unknown.png zip.png

Then run the ppsspp core again in RetroArch… the garbled characters should be gone. If it didn’t work, you can just run the standalone PPSSPPDL.app .

1 Like