Genesis 4-way Play issues

I’m sorry if this is not the best place to put this. I use PS3 retroarch mostly, but I suspect that regardless of the platform, I would be encountering the same problem, which is why I believe this is more of a general concern.

I recently upgraded to the new Retroarch version for PS3 this year and everything has been great, after getting used to the new menus. However, for the first time tonight I tried to play a game made for more than two players, and for the life of me, I simply could not figure out how to get the game to recognize a 3rd or 4th player.

Previously I had been using an older version of retroarch. I found it was frustrating to find just the right configuration for each game to get it to recognize all three controllers (is it 3button, 3button+4-wayplay, 3 button? or is it 3button+teamplayer, 3button, 3button, or is it…?) But eventually I would figure it out, remember it and all was fine.

But on I just can’t figure out how to get it to find players 3 and 4. I see that the settings have changed. Invoking the 4-way play or teamplayer is now done using the core menu, and each individual controller is set independent of that, so you can simply set at the core level whether there’s a 4-player adapter plugged in, and if so, which one. It looks like it was made to be an easier, more intuitive system but for whatever reason, it is not.

Obviously players 3 and 4 are turned on and lit up. I have tried all possible combinations of 4-way adapters and controllers and nothing will get that player 3 and 4 to work. Does anyone have the magic formula?