Getting a "Not logged in" error for RetroAchievements on Xbox Series S

I’ve been using RetroAchievements in Dev Mode on my Xbox Series S for over a year now, and it suddenly stopped working a week ago. Now, whenever I boot up a game, the RetroAchievements won’t load, and when I check the list, it says “not logged in” even though all of my login info is correct. I got the same error on my PC, and after doing some digging, I was able to fix it by removing the “cheevos_token” line in the retroarch.cfg file. This only worked on my PC, but not on my Xbox for some reason. The same issue does NOT occur on Xbox when using the standalone Duckstation app either, so something is wrong with RetroArch on my XSS, but I have no idea what.

I’ve tried everything I can think of:

  • Reinstalling RetroArch: doesn’t work (I’m on 1.9.14 now btw)
  • Complete factory reset of my XSS: didn’t work
  • I bricked Dev Mode in the process (nothing showing up on S: drive, everything is on D: drive now), but whatever, Retail Mode runs just fine, but still has the same achievements issue.
  • Deleting old cores and using new/different cores for some platforms: doesn’t work

I have absolutely no idea what’s causing this, and why it’s only happening in RetroArch on Xbox. Any help would be greatly appreciated!