Getting very inconsistent speeds when using fast forward

I’m running RetroArch 1.8.8 on macOS 10.14.6. For the most part it runs great, but whenever I use fast forward I see some strange behavior.

When in fast forward, the speed the emulator runs at varies wildly over the course of a minute or so. It usually starts out at around 300-400 fps, but then eventually slows down to around 120 fps. It’ll typically stay there for a while, and then eventually drop down to around 60 fps, as though fast forward is not running at all. At this point the game is playing a very framey, stuttery way. And then eventually it’ll pop back up to 120 fps and stay around there.

This happens with every core I’ve tried so far, including ones that aren’t computationally expensive like NES cores. I’ve tried turning off a variety of options, such as V-Sync, rewind, hard GPU sync, run-ahead, and audio, but none of them have any effect. The max throttle setting doesn’t affect the issue at all, aside from limiting how fast it’ll run when fast forwarding.

Is there anything I can do to fix this and get a more consistent fast forward speed?

Specs:
2017 27" iMac
macOS 10.14.6
4.2 GHz Intel Core i7
Radeon Pro 580 with 8 GB of VRAM
32 GB of system RAM

Bumping this as I’ve done some more investigation. I’ve discovered the trigger for the issue is having a second display connected. When the display is disconnected, games run flawlessly as does fast forward. As soon as it’s connected, the fast forward frame rate becomes very slow and inconsistent. There doesn’t seem to be any settings I can change to affect this issue.

As this seems to be a bug, I’ve created an issue for it in RetroArch’s github page here: https://github.com/libretro/RetroArch/issues/11455

1 Like