GPD XD Retroarch handheld borders shaders not working


I am facing an issue with Retroarch (1.3.6 stable and nightly) on my GPD XD, Handled borders shaders are not working for GB, GBC and GBA. I am using a Kitkat legacy rom (android 4.4.4). Some of other shaders are working perfectly fine, but I’d really like to use those borders one. Is that a known issue? Do you have any clue?


I believe someone else had mentioned something about that. Is it a totally black screen? Does the non-border version of the shaders work? (that is, the regular gameboy shader and the lcd-cgwg shader)

No black screen or borders at all, it just feels as not applied at all, display remains the same. Even when selecting the preset, it seems just not recognized. I don’t know where to find logs, if any, maybe that could be useful.

You need to use adb debugging or a logcat program to see the shader errors.

Here you go sir, I hope it will be useful and thanks a lot for your help! Logs.txt (17.1 KB)

Hmm. Looks like it doesn’t like the GRID_STRENGTH parameter. Which shader preset were you trying to load, exactly?

I guess it was gba-3x.glslp from package shaders_glsl/handheld/console-border downloaded with the online updater. But any of the presets from the package console-border gives the same result, they all have the same GRID_STRENGTH = “0.050000” value.

Gba-3x.glslp (or any “x”) never worked on my GPD XD, but the “fallback” version does.

Hi Tromzy, I’ve tried already, fallback versions don’t work either. Which Rom/Firmware are you using? I suspect this to be linked with the support of open gl in the legacy Kitkat rom I’m using.

I would try just removing the GRID_STRENGTH parameter references from the glslp.

Superpuissant, try with the “new mali drivers” of my legacyrom, but if it’s a mali issue, there is nothing can be done. Mali libs are binary blobs which are not open source, so we depend on rockchip/arm/mali people. In this sense my firmware is the same than stock firmware (Gpd introduced new mali drivers from 3.4.3 firmware) .I personally don’t suggest the new mali drivers because some Android games have issues and emus like uoyabause are slow with that, but you can try to see if the issue get fixed for you.

Which versión of legacyrom are you using? The standard called null joystick or the one called new mali drivers? Try changing versión to see if it works. But mali libs are the same than Gpd stock roms, which are close source unfortunately. Gpd introduced new mali drivers in 3.4.3 firmware which are the ones from legacyrom new mali drivers versión. The standard versión uses the mali libs from 3.4.2 firmware which are better in my opinión, specially if you run uoyabause.

I use the Legacy Rom too.


So I’ve tried to remove the GRID_STRENGTH parameter, then get another error with parameter SCALE. I’ve removed it also, just to see, but still doesn’t work. To be honnest, I’m about to give up, too bad those shaders were looking great on my PC.

It sounds like it just doesn’t like the parameters at all, which is a problem since those border shaders depend on them. You could hardcode the values, but you would need separate copies of the shader files for each preset instead of being able to pass the values from within the preset.


I also have a weird problem with my GPD XD+ (using Android 7 CleanROM). I am using the GameBoy border shader, which works nearly perfect. The problem is that I have a black line at the bottom of the GameBoy screen.

Can someone please help me with this? I’ve tried pretty much everything I can do, which probably isn’t that much. Btw: Sorry for using this old thread. I am not able to create new ones atm and this one seemed to be the best one to use.