Guide: How to integrate X360ce with Retroarch

Hi everyone. First of all, I wanna make it clear that I’m not a dev or mod or anyone directly linked to the RA team. Heck, I’m not even an active forums user. But, one thing is for certain, I’m a big fan of RetroArch and have been using it for years.

So, in my years of using it, I came across a GREAT annoyance. And that is, re-configuring all the controls when an old one is disconnected or a new is connected. I know I know, “Autoconfigs” help but I never got the hang of it.

Another problem is, when multiple “Generic USB Joystick” are connected, they DON’T HAVE ANY NUMBERS! (For those who don’t know what “Generic USB Joystick” is, they are cheap Chinese DInput controllers. Not bad for emulated games)

Yet another problem is “Deadzone” I’m pretty sure RA doesn’t have it.


Xbox 360 Controller Emulator (AKA x360ce)

It can help with the problems listed above. But anyone who tried to integrate XCE with RA knows that it doesn’t work. But after HOURS of trying, I finally managed to do it.


Download x360ce 32bit or 64bit (Depending on your version of RertoArch)

  1. Copy x360ce file to Retroarch folder.
  2. Open x360ce (download configs and setup if it’s the first time)
  3. Go to game settings tab.
  4. Click “Add” then “Retroarch.exe”
  5. Check all 64-bit boxes in Xinput Files and “DInput File” 64-bit “asiloader.dll” (I don’t what this dll is or even if it exists. All I know that you have to set this)
  6. Go to “Controller 1” tab> “Controller(NAME)” tab> map to> set the current controller number. (1-4)
  7. Repeat for Controller 2, 3 and 4.
  8. Save and exit x360ce
  9. Open Retroarch > Settings > Driver > Joypad Driver and select “sdl2” and exit. (For some reason, the newer versions of sdl2 doesn’t work with this method. So, download this this old version and replace the newer one.)
  10. Open Retroarch again and if everything is done right, you should hear a beep and you should be able to control the menu with your mapped “Controller 1”

If you come across any problems or if you require any further help, feel free to reply here or PM me. (I don’t even know if this forum has a PM option :stuck_out_tongue:)

Thanks for reading and have a nice day :relaxed:


Looks good, and thanks for sharing :slight_smile:

1 Like

It’s not that it helps, what you did is 100% covered by autoconfigs (both mapping and naming issues). And i wouldn’t recommend using an additional layer like x360ce for mapping in retroarch since it will probably add some input lag (but perhaps @hunterk will say otherwise ?)

Dunno, it’s certainly possible.

Would this program let me map duals hocks like Xinput?

Hey friend, the SDL2 Version that you have linked seems to be 64 bit, Im trying to put together retroarch on an old 32 bit machine, do you know by any chance where can i find the appropriate version that i need?? Thanks in advance.

1 Like

I’m sure you can pick up a working “sld2” from the old stable versions. Sorry I can’t test it out myself. Feel free to try it out and let me know how it goes :slight_smile: Stable 1.3.6: Stable 1.4.0: Stable 1.4.1:

Sorry. I never tried any DualShocks with this and currently I don’t have any to test. BTW, are you talking about DualShock 3 or 4?

For DualShock’s (official and fake ones) I use this tool.

Latest stable version works fine.

1 Like

I’m going to try this as soon as I get home, thank you.

Hello! Sorry to bump this but I’ve recently been trying this method to hopefully get rumble working through my Wii U Pro Controllers with the Mayflash Adapter. Well following this guide so far I can get Retroarch to recognize the X360 controller and I can control the game perfectly fine but this doesn’t seem to make a difference as far as making rumble work. In X360CE I can test the rumble perfectly fine. Does anybody know of anything I may have missed?

Hello, this topic is a bit old but I’m stuck with same problem than Abwezi, I can use my dualshock 2 controller with x360ce and sdl2 on retroarch, but rumble is not working. Rumble test is OK on x360ce.

Any idea? Thanks!

EDIT: rumble seems to be OK, I had it with Gran Turismo, with my dualshock without xinput wrapper (so in dinput). But it doesn’t work on many games (CTR, FF8), I guess it’s an other issue.

Thank you so much!!! (registered here just to say thx )) )

1 Like