[Guide] Play Neo Geo CD games using FBNeo

hi thanks again for the neogeo cd support on fba. I have read that run ahead feature will be compatible but after some test it doesn’t work. is it still in progress ? thanks

Thanks for the report, ngcd is still being worked on actually, but i didn’t know read ahead and rewind were having issues (savestates work though).

1 Like

ok thanks no worries we will patiently wait for this marvelous feature regards

I’m venturing into NG-CD emulation for the first time. I downloaded some games and all came as a .zip file, which after being extracted presents 1 .iso file, 1 .cue file and several .wav files. When pointing to open the .cue file of any game, the bios screen appears for about 3 seconds and then the Retroarch crash and close.

After reading the posts above I believe it is because of the format of the games that I downloaded. Is it possible to somehow convert the games I already have to the correct format? If so, how could I do this?

I am using Linux Mint 19.1 with retroarch and all cores updated.

ISO is not supported any longer. Google is probably a better source for methods to convert the iso to bin, but honestly it’s likely easier to find the correctly formatted files in this case.

@McCloud @zachmorris As i mentioned previously, “CDmage” is an amazing freeware which allows you to convert ANY iso format to the fba-compatible single file bin/cue, and it is really easy to use :

  1. File > Open > select your iso
  2. File > Save As > write the name of your new file
  3. Make sure you select MODE1/2352 in the second drop-down
  4. Press OK, wait for the process to finish, and it’s done !

CDmage is also working perfectly through wine on linux.

@SkyHighGam3r I just pushed the fix for Last Blade 2 on github.


@BarbuDreadMon First of all, thanks for the tip. I was able to convert the .iso file and now the game starts and is perfect playable. But no music plays, just confirmation sounds and characters voices.

Comparing the two .cue files, the first referring to .iso and the second referring to .bin, it is perceived that the problem is in the tracklist.

I simply tried to copy the codes for the tracks from one file to another, but besides not working, it also made the FBA not even open the game.

How should I proceed to make sure the tracks are correctly recognized and played during the game?

Maybe you loaded the .iso file in CDmage ? You must load the .cue file, and you are supposed to see the list of tracks at the left of the window after loading it.

Oh god, you are right. My mistake.

Converted again using the .cue file and now everything is working perfectly.

Thanks a lot for the help.

@BarbuDreadMon Thanks for the Last Blade 2 fix. It works beatifully.

Too bad this core does not support CHD, otherwise I would be using this core for NeoGeoCD emulation instead of mame. Would you be interested on adding support for chd if I open a bounty for it?


1 Like

barbudreadmon has said that they don’t personally plan to implement CHD support. In my opinion that would be the perfect reason to start a bounty, in order to attract someone else who is willing to.

CHD support has been added to many cores at this point so it’s quite possible another coder will become interested. What we do know from this thread is that FB Alpha’s maintainer has repeatedly asked to stop being asked this question. :slight_smile:

If you start an issue on github hopefully it can also move discussion of CHD to a more appropriate location. Please feel free to tag me in the issue as I’ll also help try to attract attention to it.

1 Like

@cubatilles @markwkidd There is already an issue opened about this : https://github.com/libretro/fbalpha/issues/143

Feel free to open a bounty about it, again i’m not against chd support (i won’t implement this myself though, i’m not interested and i think some developpers are more familiar with the format than me), as long as it doesn’t break anything.

1 Like

@cubatilles I put five dollars on the existing issue to start a new bounty here: https://www.bountysource.com/issues/70116022-request-chd-support-for-neo-geo-cd

1 Like

Thanks @markwkidd. I’ve just put 5$ more. Let’s hope more people is interested and we get a good bounty.


how i wished that CHD support can be a frontend feature instead… which means retroarch should be able to open any CHD (cd image at least), unpack in in memory and then run some sort of callback to fetch the unpacked tracks/cue. this could benefit any core that uses cue-based cd images converted to chd. of course this would mean more memory footprint and old, small memory devices will be affected. (thats why its just a wish)


I guess in theory it should be possible. I would donate if someone opens a bounty.

1 Like

How do these bounties work? Like does it only withdraw funds if it’s completed or something? I’m def interested in supporting it though, would make my life much easier to use FBA like I do with AES games than with MAME (god I hate MAME…) since my CD and AES games are all in the same wheel on HyperSpin.

Haven’t had a chance to sit down and extract my LB2 copy to try the fix as of yet, but it sounds like it’s working for multiple folks, and I really really appreciate that. I was very interested in playing this (possibly more than any other NGCD game) on the CD format.

Here is an overview on how the bounties work: https://docs.libretro.com/development/bounties/

Ok, so I finally had a chance to pull up Last Blade 2 and I’m very impressed with how well this core is handling NGCD games. The speed of loading is so much of an improvement over MAME. It seems like it runs on it’s own at what I’d have to hit FF to get on MAME lol. (Also, this game’s soundtrack is pretty great)

That being said though I am running into a problem… It’s a touch hard to describe.

I’m using CRT Res Switch, and using the debug tool for that I can see that when I load an NGCD game that it calls on a vertical resolution of 224p. So far, so good, 224p works wonderfully on all the many cores that use it. Double-checking online, I can see that is indeed the NGCD resolution as well. Golden.

This is where it gets interesting though - It’s not displaying the game at 224p. If you turn on integer scaling, you can see it’s in a much smaller display area, which would make sense without CRT Res Switch, but with CRTRS on you should only get 1x vertical resolution. You can also verify it’s not outputting the correct resolution by throwing the interlacing.glsl shader at it, as it will only work at integer levels.

I am unsure if this is related to it being a subsystem of fba? or maybe the NGCD bit is just not outputting the correct resolution or something? What I’m really hoping is that someone can try loading an NGCD game with their CRT setup and see if it produces the same result.

If it wasn’t just the 224p resolution, I’d assume it was something I was doing and not even bring it up, but all my other 224p games pull up perfectly.

Thanks for the report, i think there might be an issue indeed : fbalpha currently render this at 320x224, however i notice the neocd_libretro core (https://github.com/fabrice-martinez/neocd_libretro) is rendering at 304x224, the ngcd wikipedia also mention a resolution of 304x224.

I’ll talk about this with upstream.