[GUIDE] Removing black top/bottom borders - Keeping aspect ratio

guide
retroarch

#1

A lot of NEC PC Engine, Sony PlayStation and Sega Saturn games have black borders on top and/or bottom. Here is a somewhat easy way to cut them away while keeping the aspect ratio… In this example I will be using R-Type Complete for the PC Engine CD.

(Please let me know if there is an easier way and I will update this guide).

  1. Start up you game. Make sure Settings / Video / GPU Screenshot Enable is set to on.

  2. Wait until gameplay so you can properly see the black borders and then take a screenshot. Open your screenshot in a photo editor and measure the width (with borders, if any) and height (without borders). Then divide the two to get the aspect ratio. In this case 1296/924=1.402597.

  3. Back to RertoArch. Go to “Options” and start cutting away the borders with “Initial scanline” and “Last scanline”. Remember to save “Game-options file” when done! (Beetle PSX needs to be restarted for you to see the changes made.)

  4. Go to Settings/Video and change “Aspect Ratio” to config and “Config Aspect Ratio” to 1.40 (taken from your division in #2). Back to your game and “Configuration Override options” and “Save Game Overrides”. Done!


#2

I found an easy way to cut borders using the “image-adjustment” shader. It has parameters specifically for adjusting borders. Although i don’t know if it’s a “correct” way or not. I only use it for N64 games that have no overscan and as a result you get huge borders around the screen in most games.

Also, this way you only need to save shader options per game rather than config overrides.


#3

I tried cropping with image-adjustment once and the scaling looked like crap. All uneven and yuck. Using the method in the OP with the scanline core options looks much better.


#4

I see how “image-adjustment” shader messes up the picture. But is there any other shader with better looking overscan options? I can’t use the OP’s method because i use two screens and these options only apply to one of them, when i use the other the picture is all over the place. With image-adjustment i get the same picture in both screens but it’s uneven.

Funny thing is that when i’m in the shader menu and press “apply settings” i can see the picture behind the UI being cleared up. But when i close the UI, it gets messed up again. Then i bring back the UI, press apply settings again, i see the picture fixed and when i close the UI it messes up. it’s like it doesn’t save the settings… There would be no problems if it did…


#5

I don’t know of any other shaders that can crop. Strange that you have muti display issues with the OP method, since it cuts off scanlines at the core level and then passes that to the frontend (RetroArch), I think.


#6

Great thing I saved this guide here, because I would never remember all this from time to time.