Having Trouble With Multiple "Mice/Trackballs/Spinners"

I am running RetroPie on a Raspberry Pi. I’m using two Ultramarc Mini PAC controllers built into a control panel from Xtensions/Rec Room Masters. (It’s the Emulator Edition Plus.) After making a fresh RetroPie install, I updated it just within the last few days (it’s 3/13/20, for the record).

RetroArch sees both controllers and can identify them. The first controller, aside from joysticks and buttons, has a trackball on it. The second has a spinner.

In searching, I found a few issue reports about the need to support multiple mice in RetroArch. It looks like that problem was solved in 2017, as best I can tell. I can’t tell what version that was. I’ve also read this thread about using multiple mouse devices. I’ve done other searching, but that’s what seems most on-topic.

I’m using EmulationStation, in RetroPie, and Mame-Libretro(2003) for an arcade emulator. The problem I’m having is that, no matter what I do, the pointer devices act like the Highlander: There can be only one. I had a mouse on the system. RetroArch saw that and ignored the trackball and spinner. I removed the mouse and RetroArch sees the trackball, but not the spinner. At this point, knowing that the last RetroPie image was done something like a year ago, I’m wondering if, even though I updated it, RetroPie is using a version of RetroArch that’s pre-multi-mice.

Of course, the main thing I want to do is to make it so I can use my trackball in games like Centipede or Missile Command and use my spinner for games like Arkanoid or Tempest - without having to change configurations. (Hey, part of the fun of an arcade system is letting friends play with it at parties, and you can’t keep changing things around every time they change game!)

I have tried using /opt/retropie/configs/all/retroarch.cfg to specify the trackball as the mouse device, then use /opt/retropie/roms/mame-libretro/tempest.zip.cfg to specify the pointer device for use. It hasn’t worked at all. Even when I try to specify the spinner for all games, the spinner is not seen.

I’m having other issues with this. In the page I linked to above, it says to use /dev/input/eventX instead of /dev/input/mouseX. I’ve tried using both and if I use the index number for the eventX path, the trackball doesn’t work. I have to specify the number for /dev/input/mouseX to get the trackball to work.

If someone can tell me the easy and quick way to get some games to use the trackball and some to use the spinner, that’d be great. But since that may not be so easy, I have a few questions that might help me:

  1. In the link I mentioned, above, it says, “Start RetroArch from the command line with the option…” I can find no command on my RetroPie system that, in any way, resembles RetroArch or an abbreviation (with or without caps). So how do I start RetroArch from the command line?

  2. I’d like verification about whether the Mouse index # is for /dev/input/eventX or /dev/input/mouseX. It only works with the mouse number, but from what I have read, that shouldn’t be the case.

  3. I’m binding the trackball to Key 1 Bind. (Is that the right way it’s stated in the menu? I don’t have it in front of me.) Then I bind the spinner to Key 2. Or at least I try to.

  4. If I can get RetroArch to recognize both devices, am I right that the way to tell the game which one to use is through a special config file just for that game?

  5. What version of RetroArch marks where the multiple mouse fix was available? And how can I tell what version I have on my RetroPie device?

Any help is appreciated, but I’m trying to focus on the questions I think will help. If there’s a better way to make it work, I’ll be glad to hear it.

This has been here a few days.

Can someone tell me if my post is confusing? Do I need to include more data? Did I write too much? Is this board low traffic and I need to post this elsewhere?

I really do need help with this issue and I haven’t found any anywhere else. What can I do to make it easier for people to help me with this?

Did you ever have any success with this? I’m trying to do the identical as you are and pulling my hair out


I’m working on it. I got it working and made up video tutorials about it, but I haven’t had time to edit the tutorials into something useable. I checked my notes and can’t make sense of them now, over 6 months later. I really need to get the video tutorials edited and get it out there. Even Xtensions/Rec Room Masters claims it’s not possible, but, honestly, I’m not sure how much tech their tech people know. He told me, before I did it, ONE person made it work and did tons of technical things to make that happen. It’s not that hard, but it’s a matter of making sure you keep the USB plugs in the same place all the time and just getting some settings correct.

At this point, my spinner, trackball, and joysticks all behave properly - I just need to get the tutorials on YouTube so others can fix 'em. When I told the tech guy I solved the issue, he was not interested in me sending them notes or anything that could be passed on to others. Honestly, I think they’re selling so many units running on Windows that they don’t really care about *nix users.

Scoobdawg - Just like the original poster, I bought a Recroommasters arcade cabinet (xtension “Emulator Edition PLUS” controller with trackball and spinner). I’ve burned up a lot more hours than I care to admit trying to initially get the games using trackball / spinner to work under LR-Mame2003 / Retroarch. But, as a few other online forums had mentioned, it is easier to just use the Advancemame emulator for those games instead…trackball and spinner work without issue, and ADVMAME is very good for vector graphics like used in Tempest.

I recently revisited the possibility of trying again to get the affected games working with the LibRetro emulators, because I stumbled across the BezelProject in GitHub that really enhances the visual aspects of the gaming interface (ADVMAME does not, as far as I’ve encountered in hours of trying, display artwork very well, if at all). But, I have not found a way to get the trackball / spinner to work properly in LibRetro - each is detected and will move somewhat, but will often lock up midway in moving / rotating on the screen. Give the ADVMAME emulator a try.


I got almost the same problem with a spinner and trackball in combination with a ultimarc ultimate I/O

This video helped me a lot how to configure it in Retroarch: https://www.youtube.com/watch?v=oOQeUbZudUA&t=205s And then this video gave me the missing link about how to use it in MAME: https://www.youtube.com/watch?v=6mujFmXJQ_0

But now… We noticed that when we play a game with the trackball and we touch the spinner we got unwanted movement. So I tought to connect the spinner via USB. So far so good but…

I can’t find a way to let retroarch keep the mapping right… I tried a game remap via runcommand but it doesn’t work. It always jumps back to “mouse 0” which is the spinner. I’m using retroarch 1.8.8 on retropie on a pi400.

@Tango You ever get around to uploading your tutorial? On retroarch, I’ve got a different mouse device bound to separate player inputs and I’ve confirmed that their index numbers are correct, but MAME only seems to recognize whichever mouse I’ve bound to player 1. Multi-mouse support appears to be enabled in my MAME settings .

I am still trying to get to this!

I had to take time to learn 3D programming so I could do some work for my new business and have had a lot of work on our lot to deal with - like cleaning and fixing things up after a 700 year flood last fall that I wasn’t going to deal with over the winter. At this point, it’s still months off. I hate that, but I am working 10 hours a day and not even keeping up right now.

Wow. Don’t burn yourself out now @Tango . Anything you can point me toward to at least get me going down the right path? I’m trying to get my arcade machine ready for a house party next weekend,

The behavior I’ve been expecting is MAME showing trackball/spinner inputs as “Mouse 2 X” or “Mouse 3 Y” etc as I configure them in the MAME UI. Is that what you ended up achieving?

Anything info you can provide would be greatly appreciated, though I understand if work is keeping you preoccupied.

I am a contributor to the mame2003-plus core, which supports multiple mice and multiple lightguns on RetroArch platforms with input drivers that allow it.

At the moment udev in GNU/Linux and raw in Windows have this support.

I don’t visit this forum often, so if you have trouble with mame2003-plus and multiple mouselike devices with udev or winraw, please feel free to post an issue to our github tracker.

Saw this after I posted to your thread. Been using MAME 2016, which supposedly has Multi-Mouse support, but maybe that’s the source of my problem. I’ll reach out on github if I still have the issue with mame2003-plus.

1 Like