[HELP] C64 Vice in RetroArch not saving disk writes

Hi Everyone.

I just joined the forums after using RetroArch on Windows for the first time. The problem I’m having with regards to the Vice (Commodore 64) core in RetroArch is that any writing to the disk from a program isn’t being done or saved.

If I use these disks (games) that have high score saving ability on the regular WinVice (not with RetroArch) the system saves the data properly to the d64 disk image that is mounted.

In RetroArch the Vice core is not saving the high scores to the diskette media d64. I checked and made sure that the Device 8 is NOT set to “Read Only” in the RetroArch configuration, so that isn’t the problem.

Can anyone help me figure this one out? I’d really like to use RetroArch as it lets me use overlay files which help fill the screen instead of the typical black bars on the sides of a 16:9 TV or monitor.

Any help is appreciated.

Thanks, John

Hmm, I’ve never had any issue writing to disks or carts. Highscores are remembered and file modification dates change accordingly.

Launching zips or 7zs perhaps, since those are kept intact? If not, please show a debug level log of the launch.

I’ve been planning to do a delta save redirection system so that saving works also with zips in practice, but no such thing so far.

[UPDATE] You can skip reading this post as I responded below with a resolution I stumbled upon.

Ok… I think I’m on to something here. Perhaps you may be able to answer the question.

First, I’m using the Attract Mode front end and RetroArch on Windows 11. With Attract Mode the “ESC” key is the default to exit back to the front end from within a game.

So… I launch a C64 d64 image through Attract Mode which launches the RetroArch Vice version and everything works as it should. I tried multiple games but for this example I’ll use Donkey Kong Arcade released in 2016. When the game is over I enter my high score and the message comes up “Saving score to disk”. You also hear the simulated drive noise.

  1. I then press “ESC” to exit back to Attract Mode which works as it should, but if I then launch the game again nothing was saved in the high score table. This is the issue I’m having with all games that save to disk.

So, I had an idea. I recall seeing an “Quit RetroArch” option within the RetroArch menu. I found it and selected it instead of pressing “ESC”. I then loaded the game back up and the high scores were there. I tried another game doing the same method for exiting and again the high score was saved and showing. So, it appears pressing “ESC” to exit is NOT the same as selecting the “Quit RetroArch” option within the RetroArch menu.

Can you, or anyone else tell me if there is some other key to press to activate the “Quit RetroArch” option without having to go into the RetroArch menu every time to do so? If there is a key combo to press, I can enter that in Attract Mode and see if that works. I did look in the RetroArch menu but haven’t found any menu to set keybinds for the RetroArch menu system.

Sorry for the long past. Thanks again for trying to assist.


Ok, I think I fixed it.

I changed the exit key in Attract Mode to something other than “ESC” and now it seems to be working. I’ll test other d64 images later when I get back home. I’m glad I figured it out as I love the overlay feature in RetroArch. :slight_smile:

I’m guessing that pressing the “ESC” key was activating the Attract Mode exit option instead of RetroArch’s and that is why the data was never saved in RetroArch. Now when I press “ESC” the internal RetroArch option is being used and that DOES properly save the data to the disk image.

Thanks Again, John.

Well that is some nasty force killing then, since I’ve always been using Alt-F4 level closing with AutoHotkey WinClose, and I use EmulationStation for launching. No difference between quitting via RA menu.