Help Compiling for Snow Leapord. What version of Xcode Required?

Last Time I used my Early 2008 MacBookPro for emulation I received much better performance running under Snow Leopard than I did while using Yosemite. I’ve reluctantly upgraded to El Capitan. I’m currently triple booting and updated copy of Windows 10, Snow Leopard, and El Capitan on the Early 2008 MacBookPro. I can not for the life of me get Xcode 8.2.1 or 8.2 to launch on my El Capitan partition. It hangs at %100 of the way of the verification process then never responds. No Xcode in the top menu bar. Have to force quit Xcode. I have SIP disabled.

I have tried asking the Apple support forum and they insist that I use a newer mac. Unfortunately my Hack Pro is in storage. It was also very frustrating accessing my apple ID because I have no cell phone reception where I’m staying.

What version of Xcode is required to build Retroarch for Snow Leopard? I have the latest version of Xcode 4.2 for Snow Leopard and I get an error saying a newer version of Xcode is required. Does SIP have to be enabled to verify Xcode? Apple couldn’t even answer that.

Interestingly Windows performance is much worse than El Capitan. Although I’m impressed with performance with Sameboy with the DMG shader under El Capitain, I am very interested to see how the performance is under Snow Leopard.