Help with CRTEmuDriver?


#1

I’m not sure where else to ask this… but I know a lot of us use CRTEmuDriver for the amazing CRTSwitchRes feature (Credit and props to @Alphanu, you are amazing.)

I’d had this working for a couple weeks, and it’s great playing my old games on my CRT. I also have my PC hooked up to an LED HDR tv as well, because this system is also my primary modern game machine. I just picked up Resident Evil 2 last night (It’s amazing) and realized… because CRTEmuDriver replaces the AMD drivers… it kills all support for HDR…

This completely destroys the uniformity of my system, as I have to swap drivers in and out and in and out to go from modern 4K HDR stuff to playing Super Mario Bros. at 240p…

I’m really hoping someone has an idea for how to maybe quick-swap drivers? Or maybe another way to force the necessary modelines into my card? I have used CRU (Custom Resolution Utility) before, but it only let’s you add like 4 custom detailed resolutions :frowning:

This is the biggest road-block I think my build has ever seen and I could really use help if anyone has some insight.


#2

Hey @SkyHighGam3r,

CRTEmuDriver is a replacement for standard video drivers. I do not think there is a way of having great 15khz relocation and HDR in one driver. If this is something you are after, a dual boot will probably be your best option.


#3

You should really have a dedicated pc running CRT emudriver hooked to your CRT and a dedicated modern PC hooked to your LED HDR TV for simplicity. Trying to mix both on one machine for the sake of uniformity is not worth the headaches.

That’s the way I have it. When Calamity designed these drivers, I highly doubt he thought anyone would use them for current gen games. That’s also why I think it’s near impossible to get CCC working with CRT emudriver as well.


#4

Thanks for your advice guys. I think I’m just sort of ‘stuck’ for now until I can figure out a way to move forward.

My singular goal since I started this journey like 6 years ago (wow a lot of time has passed haha) was to build this one amazing console to play everything from Pong to the latest releases (Resident Evil 2 atm) through a single unified interface, something so incredibly put together that unless you peeked under the hood, you’d never know “Gam3B0x” wasn’t a professional product. The very goal is a ‘no compromises’ sort of dream. I know, I know… you can’t always have your cake and eat it too…

I’m determined though… I’m gonna find a way to make this work. I’ll be sure to share when I find something. <3


#5

I DID IT! I DID IT!! I DID IT!!! I DID IT!!! (With one issue)

Spent so much time looking at other modeline software like soft-15Khz, found some Spanish program called winmode, tried to find things in the registry manually, banged my head against the wall for some time… and then I circled back to Custom Resolution Utility… Turns out my version of this program was quite out of date. With a new version I was able to create something called ‘extension blocks’ which allowed me to add more than the 4 detailed resolutions I could before.

I’m having one more odd problem though, and it’s only with a particular resolution

  • 1920x192 <— This one.
  • 1920x224
  • 1920x240
  • 1920x256
  • 1920x448
  • 1920x480
  • 1920x512
  • 1920x576

I’ve got them all running at 120hz, and it works great… except for Master System games. For some reason when it tries to switch to 192p, my monitor displays an error and makes a fizz noise and goes to standby. I tried upping the refresh to 140hz, and now it shows video, but it won’t size the picture correctly. It looks to me like it’s not pushing the empty scanlines out. So instead of

<--active-->
<---black-->
<--active-->
<---black-->
<--active-->
<---black-->

It’s just…

<--active-->
<--active-->
<--active-->

So the screen is (>smooshed<) vertically. I thought it was just my monitor position settings at that resolution, but vertical stretch was already at 80, so moving it to the max of 100 did nearly nothing.

I’m not sure why it would struggle with this one random resolution so much.

If nothing else though… I totally got it working! I can now bounce back and forth between HD+HDR games and old school stuff like genesis without compromise.

EDIT: PAL PSX games are having odd behavior as well… resolution isn’t switching, and the bios looks like it’s in a tiny window, then the game kicks in and it’s at my desktop res.


#6

192 height resolutions won’t work without adding borders (same as the real hardware would) so it sounds like it’s just trying to display without borders which is impossible.

CRU has messed with something along the line because retroarch would always add these borders afaik. @Alphanu Is this true of windows builds?

I honestly believe in 2019 there’s no reason not to have a cheap PC running 15khz stuff (preferably running linux). It’s just too complicated to have the same machine playing modern games.

It’s a shame but then up till a year ago retroarch couldn’t even handle 15khz properly so I feel like we have to be thankful we have come this far and especially thankful it’s still being worked on and improved!


#7

Yes, a 192p resolution will be output at 200p as this is as low as windows can handle. Of course, as @Retrorepair stated this will ad boarders top and bottom.


#8

I absolutely agree, and I hope I’m not coming off as ungrateful or anything. I’m extremely thankful for what has been done with CRTResSwitch, and RetroArch as a whole. I don’t expect anyone to alter the software or do anything to make my situation ‘just work’ or anything like that. I am very very grateful for what we have here.

I entirely understand, there are definitely a million easier setups I could pursue to play retro games - that’s just it though… It’s no longer about just playing video games for me. Hasn’t been, for a few years now actually. When I’m at work all day, all I can think about is the next tweak, upgrade, or w/e I can do to my Gam3B0x. I get far more of a thrill from playing around there than I think I ever did playing games. (Which if you knew me, that’s certainly saying something) This is especially true when it involves a “Can’t be done” scenario - like when I made custom physical media for the system that works with RetroArch.

This is good to know, I will try seeing what happens if I play around at 200p instead of 192p.

Anyway, I know I am crazy, and insist on doing things the hard way… but as I always say "Nothing easy was ever ‘worth it’. " :smiley: I’ll pop back soon once I give 200p a spin, in the meantime I’m going to obsess about the PAL PSX issue today between my work calls lol.


#9

Well PSX PAL is fixed! Turns out the issue there was the cropping option in CORE options (not to be confused with “Crop Overscan” in video settings) It was just destroying the PAL resolutions. Now it calls on 288 and 576 just fiiiiine. :smiley:

I tried using just 200p, but still no go on those 192p systems.


#10

BOOM!

200p is working now. I had to set the refresh rate to 140Hz, and then I also had to turn off integer scaling. I never would have considered it, but I ran a google search and Alphanu one of your responses in another thread made me try it haha.

Anyway so that’s it… CRU is fully functional for CRTResSwitch, no more special driver installs from CRTEmuDriver, no interference with my HDR LED - it now ‘just works’ :smiley: Probably are some wild arcade resolutions that aren’t setup yet, but I’m not sure what games I could test for that, I’m very much a console-guy. haha

Thank you for your input guys, it actually helped a lot by pointing me in the right direction. Once I have a little more time I am gonna write up a quick guide on how to set CRU up for this instead of CRTEmuDriver, I’m sure there are a few folks who have graphics cards that aren’t compatible with it, so I think it might be helpful. Maybe not, I don’t know.

With that though… I got my cake, and now I’m off to eat it too :stuck_out_tongue_winking_eye: <3