How do I Disable Hotkeys in Certain Cores?

Hi I am attempting to use DosBox to emulate some old DOS games. I have run into the issue of whenever I attempt to type on the keyboard, I have to deal with the hotkeys built into retroarch. Is there a way I can disable some or all Hotkey Functionality in certain cores?

Thanks

Yes, there are two ways:

1.) map the ‘enable hotkeys’ hotkey in settings > input > input hotkey binds and RetroArch will stop listening for hotkeys unless/until you hold that button/key

2.) enable the “game focus mode” (mapped to scroll_lock by default) and it will send all of your inputs to the core instead of the frontend. However, some people have reported having trouble getting out of game focus mode, so YMMV

2 Likes

Hey Hunter, sorry for bumping this old thread, but I am configuring Typing of the Dead for the Reicast core, and the keyboard is sending the hotkeys.

Is there a way for disabling the hotkeys only for this specific game? Since just this one uses the keyboard.

Thanks!

Unfortunately, hotkey binds can’t be saved in overrides (it’s just a quirk of how the input and settings stuff work). However, you can manually add a hotkey assignment to a core override using a text editor. Sadly, it will get wiped out if you re-save the override, but you can always add it back or set the override to read-only (but be sure to remember that if you try to save a new one!).

Awesome gonna test it out later. Thanks!

EDIT: Worked great!

Excellent topic @pandg2. When I use the Amiga core, f.ex. H is mapped to Reset, so I can’t type or play games that use keyboard. I’d like to use my Bluetooth keyboard to send keypresses to the emulation.

@hunterk there’s no Settings menu or a Game Focus alternative in the Android version of RetroArch. I have also not found any setting pertaining to the issue.

There is definitely a settings menu in Android. Look for the gear icon down at the bottom of the screen.

Thanks @hunterk. It is now Gear Icon (on Home row replacement thingy) > Hotkeys > Hotkey Enable > set a key e.g. f11.

I actually did this editing the .cfg, and it sort of worked. You have to hold the key down for a little bit for it to take, you can’t really type, and ‘S’ added a space after it and ‘P’ didn’t work. (I only tested Alphanumeric.) But it’s at least possible to play some flight sims I guess.

This could be an issue in P-UAE? If so I have no idea how to make this work :sob: