How do I unbind keys?


#1

I can’t seem to unbind keys from the menu, and I also can’t back out of changing something (It says I need to press RETURN to skip but I’m not sure what that means as nothing seems to work). I can unbind keyboard binds just by waiting, but joypad binds don’t seem to work that way :confused:


#2

If you want them to return to default, there’s a menu entry that does it. If you want things straight-up unbound (for example, because you don’t want to hit something accidentally) the best way to do it is to open your retroarch.cfg and change the default mapping to “nul”.

input_rewind = “r” becomes input_rewind = “nul”


#3

The weird thing is, that worked with the keyboard key, but the accidental hotkey I made with the joypad stayed, even though it was changed from button 0 to nul. It’s like the setting just wouldn’t apply.


#4

Hmm. That’s weird. Is there any chance you have a conflicting config somewhere (core-specific or override) that’s making that mapping linger?

If all else fails, move your retroarch.cfg somewhere else and see if it’s still doing it. If so, you have another config somewhere causing problems.


#5

If I put away the CFG it disappears, but Lakka disappears as well.

I reproduced the problem. I wanted to use the turbo button. But I can’t remove it anymore. Neither from the GUI or the cfg file. I just can’t remove joypad binds, only change them. I can however remove keyboard binds both in menu and in the cfg file.

What does work is: 1 - Go into cfg file and change bind to nul 2 - Copy cfg file somewhere 3 - Remove the cfg file in the retroarch folder 4 - Start up retroarch 5 - Replace the cfg retroarch created with the old one

Pretty weird.

This is 1.2.2 windows, I don’t know if it happens in nightly builds.


#6

If you remove the config, lakka’s fancy pictures and stuff disappear until you re-set your ‘assets’ directory. If it’s acting weird, that’s going to be your safest solution to zero out any weird manual edits you’ve made.


#7

The thing is, I should be able to remove binds in the GUI like I can with keyboard keys. Just wait a few seconds and they unbind. But with the joypad I can’t do that for no real reason. I think it not working when I edited the file had to do with me messing up something with configuration per core. All in all it’s fixed now.

Buit, do you know how I can disable certain mame hotkeys for the gamepad? L2 is opening the menu and R2 is turning on the frame skip menu. L3 is resetting the game. The first is set to keyboard tab in mame, the third was on Lshift. Not sure about the second. Why does L2 equal tab anyways? 0.o


#8

Yeah, that’s the fault of the guy who originally did the MAME port. Instead of doing an actual joystick interface, he just auto-bound a bunch of retropad stuff to key events in the core. You’d have to go into the MAME OSD menu and unbind them there.


#9

Ah, that makes sense xD.


#10

Hello guys!

The quick solution I found that did not require manual editing was to bind any key you don’t want to use by mistake to the same button as the “Exit” key.


#11

I thought you can use retropad x to clear a binding. Highlight the option (dont start binding) then hit x


#12

Hi, I am new and cannot start a new thread.

My question: I just set up retropie and got SNES running. However, for some reason my down button is defaulted to the DOWN button my Buffalo pad. I went into retroarch and made the changes as I have seen in videos and posts. Currently, my “enable hotkey” is 6 for select but as I play and I hit down simultaneously with another mapped hotkey, it performa that action.

How do I stop the down key from functioning as the Enable Hotkey button???

Current limitations: i dont have a keyboard, i use OS X, limited programming experience

Thanks!


#13

Controller problems.

REMOVING DELETING RETROARCH FROM CONSOLE.

I searched for 3 hours on every forum, and there was no solution to removing retroarch completely from a game console.

If your playstation or nintendo console’s controller does not work in the Retroarch Menu, and you can open retroarch , however you can not navigate/work the menu, then the drastic option is to delete retroarch from the console hard drive. If you re-install retroarch, this fails to remove the INPUT HOTKEY BINDS. You still receive an AXIS controller conf error when you connect the controller after re-install.

As my retroarch was quite new, I just FTP into the Playstation 3 and then deleted the DEV_HDD0/SSNE10000 folder. Just do a search in FTP for “retroarch” and you will find the retroarch.cfg file. (Make sure Multiman in running or FTP does not open your hard drive on the PS3)

Re-Install Retroarch and your good to go. Slots are refreshed.

Rebug 02.02.15 Firmware 4.82 Cobra 7.54 Retroarch 1.7.2 or 1.7.1 Sony PS3

You can then FTP games into a new folder like DEV_HDD0/ALLROMS and its easier to FTP instead of using a USB stick.


#14

I don’t get it. I also have that issue now. I used the select button of my playstation controller as a hotkey for screenshots. Now I want to unbind it and don’t know how. Is there really no easier way than editing the retroarch.cfg file? That really surprises me. Highlighting the option and pressing x doesn’t work for me.


#15

Try hitting retropad-start or the ‘del’ key on your keyboard.


#16

The del key didnt work, but start did. Thanks a lot :slight_smile: