How to I set RetroArch to fullscreen?

Hiya. Sorry for the basic question but I’ve been looking everywhere with no luck. I know you can set fullscreen to on in the settings but when I exit and relaunch RetroArch, it goes back to windowed. Also the Genesis Plus GX core also doesn’t start in fullscreen, even if fullscreen is set to on in the RetroArch settings. I also did click on the save settings option. Now, even if that setting is only for the RetroArch GUI, I also can’t find any settings at all in Genesis Plus GX anyway. Actually I can’t find any settings at all for that core, I’m clearly missing something obvious. I wanted to try the screen borders that are available for RetroArch but I can’t even find basic options before getting to that point.

Any help would be great, thank you for your time.

Hmmm unless you enabled per-core configs it should always respect the settings from retroarch.cfg Try the getting started guide here: http://www.libretro.com/index.php/getting-started-with-retroarch/

In video settings in the GUI (Video>Use Fullscreen Mode), or you can run from command line with -f argument.

I also recommend activating Windowed Fullscreen Mode, IIRC it’s like borderless windowed, allows for easy Alt-Tabbing.

Are you sure you aren’t forgetting to save the settings? RA can save on exit (not recommended if you use it as a standard emulator with a GUI), or manually, or it can save to a different config, of course. Pressing “Esc” (or equivalent) while running a game will NOT save your settings on exit, though.

I also don’t recommend activating “Configuration per Core”, instead you should have multiple configs and load them whenever appropriate.

[QUOTE=Radius;34087]Hmmm unless you enabled per-core configs it should always respect the settings from retroarch.cfg Try the getting started guide here: http://www.libretro.com/index.php/getting-started-with-retroarch/[/QUOTE]

I did use that guide, was the first thing I did. Thanks, I switched off Per-core configs and it fixed the issue. I read in another guide that I should switch that on, but it looks like they were wrong. The emulator also starts in fullscreen as well now. I also randomly pressed F1 and discovered that’s how you get the options for the core, I did’t know that before.

[QUOTE=Zpectre87;34099]In video settings in the GUI (Video>Use Fullscreen Mode), or you can run from command line with -f argument.

I also recommend activating Windowed Fullscreen Mode, IIRC it’s like borderless windowed, allows for easy Alt-Tabbing.

Are you sure you aren’t forgetting to save the settings? RA can save on exit (not recommended if you use it as a standard emulator with a GUI), or manually, or it can save to a different config, of course. Pressing “Esc” (or equivalent) while running a game will NOT save your settings on exit, though.

I also don’t recommend activating “Configuration per Core”, instead you should have multiple configs and load them whenever appropriate.[/QUOTE]

Thanks for the tips. How do I exit the core without exiting RetroArch completely? I press Esc which shuts down everything!

Just press F1 :smiley:

Ah yes sorry, I’d forgot I’d already figured that out. I was kinda thinking more like, how would I set that to buttons on a controller. I think I figured it out though; went to options and set L3 and R3 both to the same button on my controller, then while in-game, I can press that to get back to the menu. Is there a way to change core settings (such as shaders) while the core isn’t running? As in, I can only find those options when I press F1 while the game is running (or pressing L3 +R3).

Sorry, also, the shader borders; Is there are way to set them (or make them) so that they fill a widescreen while a 4:3 game is running in the middle? So that the left and right of the screen has something instead of black borders. Like the image below;

There are a couple of ways to handle the black space on the sides. The easiest is probably to use an overlay. It seems all of the ones in the repo are intended for integer scale, rather than 4:3 scale-to-fit, but it’d be easy enough to make one that does what you need. Just make an image that does what you want (i.e., 1920x1080 or whatever, with an appropriately sized transparent box in the middle) and replace one of the images in the ‘border’ directory.

Thank you hunterk, I’ll look into that.

How do I set Retroarch to exclusive fullscreen? It seems to be using borderless regardless of what setting I pick. Borderless windowed is turned off, yet it’s still borderless.

It should just work when you disabled windowed fullscreen. How are you determining that it’s not working?

If you set video_fullscreen_x/y to something like 1280 x 720 in your retroarch.cfg, it should try to change your display’s resolution if exclusive fullscreen is working properly.

If it’s not working, it’s probably something your GPU’s control panel stopping it.

Because Skype’s screenshare normally does not work with fullscreen games, yet here the red border appears. It alt tabs instantly, and other things can go on top of the retroarch sceen. Meanwhile, if I put it on Direct3D, all of this does not happen. However, that’s really buggy, has an ugly menu and keeps crashing.

I can also use ShareX (a screenshot program) on Retroarch, even though I can’t do that with other fullscreen applications. Is it just that it automatically switches back to windowed fullscreen whenever you use anything else? Because Retroarch’s menus feel more responsive than other windowed modes I’ve tried.

I don’t have this problem anymore! I don’t know how it works but sometimes it’s on exclusive fullscreen and sometimes it isn’t, but it always has something to do with either me alt tabbing , another program taking the top layer, or starting a new game. Sometimes my mouse will feel perfectly fine and then at other times it lags behind indicating it is borderless window. But I can just fix it by restarting retroarch going from window to fullscreen.

this has affected me for ages. still plugging away looking for a fix. Issue is here if you want to chime in https://github.com/libretro/RetroArch/issues/7430#issuecomment-489467920

1 Like