How to make dualshock 3 triggers respond instantly?

controller

#1

I’m using a Magic NS adapter with a dualshock 3 in Retroarch, and the sensitivity of the triggers seems to be wrong when mapping them to digital buttons. This is noticeable for ps one games that use all 4 shoulder buttons or any core where I want to remap the controls. The triggers require much more force than is necessary to get them to activate the corresponding button in game.

I can test this by using Joytokey and setting up a profile mapped to keyboard keys. I disable the xinput device in retroarch, and then map the retropad abstraction controller to the keys I set in the Joytokey profile. When I do this, the triggers respond much quicker because Joytokey is handling the analog to digital response.

It doesn’t seem to be an OS problem because the triggers respond very quickly when testing them in the Windows joystick configuration utility and in other applications such as Joytokey as just mentioned. Using a dualshock 4 with the adapter gives the correct response.


#2

You can try changing settings > input > analog stick deadzone from 0.5 to 0.1. Note: I think the option has been renamed in the nightlies because it’s not really about analog stick deadzones, but rather analog-to-digital thresholds.


#3

Ok, for some reason I thought that only applied to thumb sticks. It’s hard to say, but the triggers do seem to react ever so slightly faster; however, I think the test I did with Joytokey is still a bit more responsive. Thanks for the reply though.

edit: Actually putting it to the lowest it will let me go, 0.051, now makes the triggers about as responsive as I’m used to. Is there some negative effect when putting it below 0.1?


#4

No, I just pulled that number out at random as a low-ish value to try.