How To Quit PCSX2 Core (solution)

If you’re having problems with quitting from PCSX2 I have a solution. I use Retroarch through Emulationstation with JoytoKey to exit standalone emulators. I haven’t spotted any yet but this may have some quirks since it will taskkill any and all Retroarch cores not just PCSX2. Let me know if you have a cleaner solution.

First create a script file with the following contents:

Taskkill /F /IM retroarch.exe

Make sure to give it the .ps1 file extention.

Then in JoytoKey create a new profile for your controller and for the button you use to exit Retroarch (often button 13) go to the Launch an external Program in the Special tab. Add the following:


In parameters add: -ExecutionPolicy Bypass -File “[PATH TO AND NAME OF YOUR SCRIPT FILE.ps1]”

Finally assign the profile to [PATH TO RETROARCH/Retroarch.exe]


I found an issue with this. If you want to save on exit it won’t work for any core win combination with this script. The solution is to quit using the escape key if you want setting to be saved when you exit.

Does anyone know if the quit issue has been resolved in the PCSX2 core yet? I use standalone now since it got updated to allow individual game profiles.

No, still the same situation.

1 Like

That’s a shame, It has a frameskip option that I can’t for the life of me seem to find in the standalone version.

I have setup the standalone PCSX2-QT in EmulationStation, you can set a hotkey to exit the emulator back to the frontend like shown in the screenshot directly in your gamepad, it works with other standalone emulators in a similar fashion, such as Dolphin, etc. This is not related to RA’s core, but maybe this could be helpful as it doesn’t need third party solutions such as joy2key, etc.